Valutazione 4.87/ 5 (100.00%) 5838 voti
Blog

Editor WYSIWYG per i commenti

webmaster: 02/09/08 @ 21:11
Come avrete visto il box per l'inserimento dei commenti delle news e di questo blog è diventato WYSIWYG, cioé potete formattare il testo che inserite proprio come fareste con Word. Non è più necessario ricordarsi come funziona il BBcode se non volete; se invece preferite il vecchio sistema, l'editor per il BBcode è sempre presente :)

Mi aiuterebbe molto se poteste testarlo e verificare che questo non causi problemi con particolari configurazione o che non ci siano bug che non ho notato.

Idee, commenti e suggerimenti sono i benvenuti.

Commenti: 10


I commenti dei lettori:

webmaster webmaster il 04 Settembre 08 @ 14:39 pm

se qualcuno potesse aiutarmi a trovare i bug, gliene sarei molto grato.
ad esempio ho appena scioperto che evedenzionado del testo e premendo ctrl-c si perde l'highlight. il testo viene copiato correttamente, ma è una seccatura.

webmaster webmaster il 06 Settembre 08 @ 17:33 pm

ad esempio ho appena scioperto che evedenzionado del testo e premendo ctrl-c si perde l'highlight. bug risolto, spero. ho trovato questo articolo interessante che mi ha dato un paio di dritte:
http://www.thefutureofthe ... web.com/blog/onafterpaste

webmaster webmaster il 09 Settembre 08 @ 09:00 am

ho sistemato un bug che causava due bbcode a essere fusi in uno solo quando si passava dalla modalità bbcode alla modalità wysiwyg. il problema era una regexp poco precisa. mi ero dimenticato che quando si vuole catturare il contenuto di due tag, è necessario bloccare la regexp al primo < che incontra, altrimenti rischia di prendere due tag di fila.
quindi non: ...>(.*)<...
ma: ...>([^<]*)<...

ho inoltre cominciato a fare qualche test su chrome e sembra che passando dalla modalità wysiwyg alla modalità bbcode si perda qualche pezzo. devo investigare meglio.

webmaster webmaster il 12 Settembre 08 @ 19:03 pm

corretto un piccolo bug per cui il bbcode tag [s] non funzionava correttamente.
il problema è che mi ero dimenticato di definire il tags "strike" nel file del bbcode :)

Dylan666 Dylan666 il 22 Settembre 08 @ 08:15 am

ho problemi con gli "a capo": se passo dalla visualizzazione normale a
quella coi tag a video alcuni vengono persi e altri no, in particolare
vengono persi gli a capo con righe bianche.

Tipo quella che c'è fra questi fue periodi

webmaster webmaster il 22 Settembre 08 @ 09:50 am

dylan, can che browser ti succede questo? solo con ie o anche fon ff?

webmaster webmaster il 23 Settembre 08 @ 23:58 pm

dylan, sembra che il problema sia più complesos di quanto pensassi in quanto è un problema di iinternet explorer. provo a trovare una soluzione, ma sembra che neanche tinymce ne sia esente

Dylan666 Dylan666 il 25 Settembre 08 @ 08:49 am

Oggi sono andato a scrivere un commento e quando premo "Invio" mi è apparso un alert con dentro scritto solo "p". Come mai?
Lo ha rifatto anche ora mentre sono andato a capo per scrivere questa riga... sto usando Firefox 3.0.1

webmaster webmaster il 25 Settembre 08 @ 09:15 am

perché, diciamocelo pure, sono un idiota.
sera, per ssitemare un bug, ho caricato una versione che conteneva ancora i miei debug. adesso ho sistemato perl. grazie per la segnalazione.

webmaster webmaster il 25 Settembre 08 @ 13:31 pm

ho problemi con gli "a capo": se passo dalla visualizzazione normale a quella coi tag a video alcuni vengono persi e altri no, in particolare vengono persi gli a capo con righe bianche.
risolto!

Lascia un commento

Insulti, volgarità e commenti ritenuti privi di valore verranno modificati e/o cancellati.
Nome:

Commento:
Conferma visiva: (ricarica)

Inserisci la targa della città indicata nell'immagine.

Login | Iscriviti

Username:

Password: