Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

formattazione primo in elenco

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

formattazione primo in elenco

Postdi marcoc » 30/11/20 00:02

ciao a tutti,
ho un file con in colonna A una serie di anni, che si ripetono (es. 2003, 2010, 2004, 2001, 2009, 2004, 2003, 2008...); come faccio a formattare con testo verde il primo in alto non ripetuto? nell'esempio dovrebbero formattarsi solo i primi 5 e l'ultimo.
grazie
Avatar utente
marcoc
Utente Senior
 
Post: 282
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: formattazione primo in elenco

Postdi Anthony47 » 30/11/20 00:32

Seleziona l'area destinata a contenere i numeri da A1 verso il basso, possibilmente non tutta la colonna; poi avvia la formattazione condizionale usando la condizione "Usa una formula"; come formula inserisci
Codice: Seleziona tutto
=CONTA.SE($A$1:$A1;A1)=1

Applica la formattazione preferita e chiudi con Ok

Fai sapere...
Avatar utente
Anthony47
Moderatore
 
Post: 17514
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: formattazione primo in elenco

Postdi marcoc » 30/11/20 21:01

grazie, ma ho paura che mi si scombina se dovessi spostare delle righe nell'intervallo; nel mio file mi capiterebbe spesso; non si perde la formattazione?
Avatar utente
marcoc
Utente Senior
 
Post: 282
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: formattazione primo in elenco

Postdi Anthony47 » 01/12/20 00:26

Si, se muovi le righe o le celle su e giu' la formattazione puo' andare in tilt.
Allora potresti usare una macro; ad esempio, da inserire in un Modulo standard del vba:
Codice: Seleziona tutto
Sub OnlyOne()
Dim I As Long
For I = 1 To Cells(Rows.Count, 1).End(xlUp).Row
    If Application.WorksheetFunction.CountIf(Range("A1").Resize(I, 1), Cells(I, 1).Value) = 1 Then
        Cells(I, 1).Font.Color = vbGreen
    Else
        Cells(I, 1).Font.Color = vbBlack
    End If
Next I
End Sub

Ovviamente la devi avviare in qualche modo; sconsiglio di agganciarla a un evento quale WorksheetChange, salvo che le celle coinvolte in colonna A siano poche decine.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17514
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "formattazione primo in elenco":


Chi c’è in linea

Visitano il forum: Nessuno e 30 ospiti