Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

CERCA.VERT XLSX CON AGGIORNAMENTO AUTOMATICO DEL FOGLIO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

CERCA.VERT XLSX CON AGGIORNAMENTO AUTOMATICO DEL FOGLIO

Postdi greensm » 21/09/17 17:54

Buongiorno, avrei necessità del vostro prezioso contributo:
su foglio "aaa" ci sono dei cerca.vert che puntano sui fogli successivi (chiamati bbb, ccc, ddd, ecc)
Poiché tutti i fogli tranne aaa sono periodicamente da sostituire (cancello quelli esistenti e li riaggiungo aggiornati, con medesimo nome), ho necessità di non perdere il riferimento nelle formule del foglio aaa (ovviamente quando cancello, i cerca vert perdono il riferimento). Avete una soluzione?
Grazie mille in anticipo
ciao!!
greensm
Newbie
 
Post: 9
Iscritto il: 04/05/17 18:56

Sponsor
 

Re: CERCA.VERT XLSX CON AGGIORNAMENTO AUTOMATICO DEL FOGLIO

Postdi greensm » 21/09/17 17:56

... eventualmente sul foglio aaa posso aggiungere l'elenco dei nomi dei fogli nel caso potesse servire.
Grazie
greensm
Newbie
 
Post: 9
Iscritto il: 04/05/17 18:56

Re: CERCA.VERT XLSX CON AGGIORNAMENTO AUTOMATICO DEL FOGLIO

Postdi Anthony47 » 22/09/17 01:23

Dovresti valutare di non sostituire i fogli ma sostituirne il loro contenuto: copi tutto il nuovo foglio, lo incolli in A1 del foglio corrente.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17446
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: CERCA.VERT XLSX CON AGGIORNAMENTO AUTOMATICO DEL FOGLIO

Postdi greensm » 20/11/17 10:15

il problema è proprio questo: non è possibile sostituire solo il contenuto in quanto i fogli sono frutto di una routine e sono parecchi: volevo evitare proprio il copia/incolla su ogni singolo foglio.
Grazie. Buona settimana
greensm
Newbie
 
Post: 9
Iscritto il: 04/05/17 18:56

Re: CERCA.VERT XLSX CON AGGIORNAMENTO AUTOMATICO DEL FOGLIO

Postdi Anthony47 » 20/11/17 20:17

Se il lavoro e' fatto da una macro costa poco aggiungere al codice della macro le istruzioni che copiano il contenuto nel foglio giusto... Purche' si sappia o si possa calcolare quale e' il "foglio giusto" che il nuovo contenuto deve andare ad aggiornare.

Una alternativa e' inserire i nuovi fogli, poi andare a modificare le formule sostituendo i vecchi NomiFoglio con i nuovi; anche questo e' fattibile con una macro... ma anche in questo caso purche' si sappia o si possa calcolare quale e' il nome del "foglio giusto" che il nuovo foglio deve andare ad aggiornare.

Oppure, e forse e' la via piu' semplice, modifichi le formule affinche' il foglio target non sia indicato come link al foglio ma come "stringa" compilata col nome del foglio. In questo modo quando cancelli i vecchi fogli la formula non cambia.
Per questa operazione devi usare la funzione Indiretto.

Ad esempio
Formula originale
Codice: Seleziona tutto
=CERCA.VERT(C3;'Nome Foglio'!E5:G100;2;0)

Formula alternativa
Codice: Seleziona tutto
=CERCA.VERT(C3;INDIRETTO("'Nome Foglio'!E5:G100");2;0)

oppure (se la stringa 'Nome Foglio'! e' inserita mettiamo in Z1)
Codice: Seleziona tutto
=CERCA.VERT(C3;INDIRETTO(Z1&"E5:G100");2;0)

Nel caso venga usato Indiretto, il nome del foglio e' una stringa, quindi non cambiera' nel momento in cui vai a cancellare il foglio a cui (in modo indiretto) fai riferimento; quindi puoi gestire la cancellazione dei vecchi fogli, se questa via ti sembra piu' semplice.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17446
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "CERCA.VERT XLSX CON AGGIORNAMENTO AUTOMATICO DEL FOGLIO":


Chi c’è in linea

Visitano il forum: raimea e 23 ospiti