Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Xampp

Risolvi qui i tuoi problemi legati a Windows '95, '98, ME, NT, 2000, XP, 2003, Vista...

Moderatori: -> EleKtrA <-, antoo69

Xampp

Postdi mick80 » 21/07/08 18:54

Salve a tutti,
ho un problema con xampp... ho settato le password per la sicurezza ed ora il mio sito non è più accessibile dall'esterno.
Non riesco a capire cosa ho fatto ma non riesco più a renderlo accessibile....
Sulla pagina della sicurezza di xampp mi da:

Queste pagine non sono accessibili da chiunque in rete SICURO
L'utente admin di MySQL ha una password SICURO
Il login con password di PhpMyAdmin è abilitato. SICURO
La password FTP è stata cambiata SICURO
PHP non è in esecuzione in "safe mode" INSICURO
Se desideri che persone esterne eseguano PHP, prendi in considerazione la configurazione "safe mode". Per gli sviluppatori consigliamo di NON usare la modalità "safe mode", poiché alcune funzioni importanti non funzioneranno. Maggiori informazioni

L'utente di test "newuser" per il server POP3 (Mercury Mail?) non esiste più oppure ha una nuova password SICURO

Come posso fare per renderlo accessibile!????

AIUTO non so più dove sbattere la testa :aaah
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Sponsor
 

Re: Xampp

Postdi Dylan666 » 21/07/08 19:29

Ma tu che password avresti messo? Sei sicuro invece che il problema non sia nei permessi alle cartelle? Chi cerca di accedere al tuo sito che numero di errore riceve?
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Xampp

Postdi mick80 » 21/07/08 21:04

Ho messo la password di MySql e la protezione della directory di XAMPP.
Quando accedo da locale mi domanda password e poi mi fa accedere, da remoto mi esce l'errore Page not found .....

Può anche darsi che il problema sia nei permessi delle cartelle, in caso come faccio per cambiarli?
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Re: Xampp

Postdi Dylan666 » 21/07/08 22:39

Quella che devi togliere è ovviamente la "la protezione della directory di XAMPP"
http://www.apachefriends.org/it/xampp-windows.html#4696
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Xampp

Postdi mick80 » 22/07/08 08:04

Scusa, ma come faccio a togliere la password di protezione della cartella di Xampp?
Ho provato a reimpostare una password vuota ma non me lo permette...
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Re: Xampp

Postdi Dylan666 » 22/07/08 08:41

Leva o rinomina questo file: .htaccess
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Xampp

Postdi mick80 » 23/07/08 16:46

Ho rinominato tutti i file .htaccess, nella pagine della sicurezza mi dice che il sito è accessibile però ancora non riesco ad accedere, mi esce sempre quella maledetta schermata che mi dice che non trova la pagina.....

Boh proprio non capisco :(
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Re: Xampp

Postdi Dylan666 » 23/07/08 17:40

Una cosa è che non trova la pagina, un'altra che non può accederci... sono due cose e due pagine di errore completamente diverse. Pagina non trovata è errore 404, accesso non consentito è errore 403.

Nella cartella dove dovrebbe comparire il sito hai messo un file index.htm o index.html?
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Xampp

Postdi mick80 » 24/07/08 19:34

Allora la schermata che mi da è:

Cannot find "http://<mio IP>/sitoweb/administrator/index.php?option=com_media"

DNS Error - Server cannot be found

Questo succede solo se cerco di accedere da remoto perché in locale funziona tutto
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Re: Xampp

Postdi Dylan666 » 24/07/08 19:35

Se come "mio IP" ci metti 127.0.0.1 vedi qualcosa? lo so che tu lo vuoi visibile dall'esterno, ma andiamo per gradi
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Xampp

Postdi mick80 » 24/07/08 19:38

Nella cartella htdocs di xampp c'è un file index.html ma non mi sembra di averlo creato io, ho usato joomla per il sito e cartelle e file sono state create in automatico
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Re: Xampp

Postdi mick80 » 24/07/08 19:39

Certo con 127.0.0.1 o localhost vedo la pagina iniziale di xampp, se aggiungo /sitoweb vedo il mio sito
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Re: Xampp

Postdi Dylan666 » 24/07/08 19:41

prendi un file di testo TXT vuoto, scrivici dentro "ciao" e salvalo come test.htm
Poi in explorere digita questo:
http://<mio IP>/sitoweb/test.htm

Vedi ciao oppure no? Stavolta la prova falla con l'ip Internet, NON 127.0.0.1
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Xampp

Postdi mick80 » 24/07/08 19:58

Non ho capito scusa, ho creato il file e l'ho messo nella cartella sitoweb in htdocs, e se digito l'indirizzo http://127.0.0.1/sitoweb/test.htm vedo la scritta "ciao"
Ho provato a fare collegare una persona da un altro pc lontano e da sempre quell'errore
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Re: Xampp

Postdi Dylan666 » 24/07/08 22:45

Quell'errore quale? Trascrizione precisa e completa per favore
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Xampp

Postdi mick80 » 25/07/08 23:46

Cannot find "http://<mio IP>/sitoweb/administrator/index.php?option=com_media"

DNS Error - Server cannot be found
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Re: Xampp

Postdi Dylan666 » 26/07/08 13:26

mick80 ha scritto:Ho provato a fare collegare una persona da un altro pc lontano e da sempre quell'errore

Inteso con il tuo IP di internet o con 127.0.0.1?
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Xampp

Postdi mick80 » 27/07/08 16:48

Inteso con il tuo IP di internet o con 127.0.0.1?


Ip pubblico di internet che è 87.28.ecc.....
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Re: Xampp

Postdi Dylan666 » 28/07/08 07:39

Ok, era er essere sicuro. Ma quindi prima funzionava e dopo non e l'unica differenza era la password di sicurezza? perché questo errore èare non aver nlla a che vedere con quello...
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Xampp

Postdi mick80 » 28/07/08 17:11

Dopo aver modificato le impostazioni di sicurezza ero sicuro che era quello... cavolo ora mi sono ricordato di aver cambiato anche il router e la porta 80 non era aperta..
Credevo che quella porta fosse aperta per default... ci credo che non andava :P
Ora funziona, mille grazie per la tua pazienza!
mick80
Utente Junior
 
Post: 40
Iscritto il: 10/01/06 17:50

Prossimo

Torna a Sistemi Operativi Windows


Topic correlati a "Xampp":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti