Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Creare un Cerca.Vert sfruttando il VBA

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Creare un Cerca.Vert sfruttando il VBA

Postdi Maury170419 » 10/03/19 13:57

Ciao a Tutti mi chiamo Maurizio
E il mio problema e questo :
Sul Foglio2 di Excel nella Colonna ( A2:A56 ) ho una lista di nomi di Città
Mentre nella Colonna ( B2:B56 ) Ho i nomi delle varie regioni
Detto questo : Io Per trovare i nomi delle Città uso un Menu a tendina che ho posizionato sul Foglio1 nella Cella ( K1 )
Mentre nella cella ( K2 ) vorrei creare una sorta di Cerca.Vert sfruttando il VBA.
Ahora quello che non capisco e non riesco a risolvere e questo :
Se il nella Cella ( K2 ) scrivo la formula :
Codice: Seleziona tutto
=Cerca.Vert(K1;Foglio2!A2:B64;2;falso)

Questo mi Funziona Benissimo; ma a me non serve in quanto ho bisogno di tanto in tanto di usare un Clear per qui di fatto mi cancellerebbe la funzione stessa.

Però ho provato a Fare la Stessa cosa sfruttando il vba ; Scrivendo questa formula :

Codice: Seleziona tutto
Foglio1.Range("K2").Formula = "=Cerca.Vert(K1;Foglio2;A2:B56;2;0)"


ma a quanto vedo non funziona in quanto mi apre il meniu documenti del mio Hard Disk
Ahora : Lo cambiato con :

Codice: Seleziona tutto
Foglio1.Range("K2").FormulaLocal = "=CERCA.VERT($K$1;foglio2;$A$2:$B$56;2;0)"


Ma anche questa volta continua a Darmi errore ; Perché e come posso ovviare a tutto ciò Grazie
Saluti da A.Maurizio
Maury170419
Utente Junior
 
Post: 83
Iscritto il: 31/10/16 09:05

Sponsor
 

Re: Creare un Cerca.Vert sfruttando il VBA

Postdi wallace&gromit » 10/03/19 15:10

Ciao Maurizio,
passando dalla formula originale a quella in vba hai scambiato un ! con un ;
ecco la versione corretta:
Codice: Seleziona tutto
Foglio1.Range("K2").FormulaLocal = "=CERCA.VERT($K$1;foglio2!$A$2:$B$56;2;0)"
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1864
Iscritto il: 16/01/12 14:21

Re: Creare un Cerca.Vert sfruttando il VBA

Postdi Maury170419 » 13/03/19 17:30

Ciao wallace&gromit grazie del tuo suggerimento , ma ti prego di credermi quando ti tico che anche io in un primo momento avevo fatto e pensato la stessa formula che mi hai seggerito tu ; Però ho dovuto scartarla in quanto mi una volta che mando in esecuzione la procedura di verifica mi vengono fuori queste due cose che puoi vedere sia in figura 1 che in figura 2.

[img][img]https://i.postimg.cc/ThTqtddS/Figura-1.png[/img] [/img]
E Poi Questa :
[img][img]https://i.postimg.cc/23TdJs35/Figura-2.png[/img] [/img]

Ma a questo punto non ti preoccupare perché nel frattempo : Provando e Riprovando a modificare il tutto sono riuscito a risolvere il tutto facendo in questo modo :
Codice: Seleziona tutto
Foglio1.Range("I14").Value = WorksheetFunction.VLookup([I13], Sheets(2).[A2:D56], 2, False)

Tutto qui Grazie comunque e scusami se ti ho risposto solo ora ma sono nel frattempo stato impegnato con il mio lavoro. Ciao
Maury170419
Utente Junior
 
Post: 83
Iscritto il: 31/10/16 09:05


Torna a Applicazioni Office Windows


Topic correlati a "Creare un Cerca.Vert sfruttando il VBA":


Chi c’è in linea

Visitano il forum: contiend, wallace&gromit e 13 ospiti