Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Integrare formula matriciale

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Integrare formula matriciale

Postdi BG66 » 14/09/18 13:13

Ciao a tutti,
vorrei integrare una formula matriciale nata nel mio thread precedente (http://www.pc-facile.com/forum/viewtopic.php?f=26&t=109952) .
In pratica :
se la cella G21 presenta la "S" riportami in M21 quanto scritto in H24 altrimenti applica la formula esistente:
Codice: Seleziona tutto
=INDICE(Legenda!E17:H26;0;CONFRONTA(Attestato!H14;Legenda!E15:H15;0))
.

La formula dovrebbe cambiare cosi:
Codice: Seleziona tutto
=SE($G$21="S";$H$24;INDICE(Legenda!E17:H26;0;CONFRONTA(Attestato!H14;Legenda!E15:H15;0))


ma non avendo capito la complessità di questa formula specificatamente matriciale ( Anthony dixit), ottengo:
Immagine.

C'è soluzione?

Grazie in anticipo.
Gene
BG66
Excel2010
BG66
Utente Senior
 
Post: 130
Iscritto il: 20/08/16 07:44

Sponsor
 

Re: Integrare formula matriciale

Postdi Anthony47 » 14/09/18 18:07

"Come sai" :D nel caso di uso di formule matriciali, piu' celle condividono la stessa formula; se vuoi modificarle devi farlo necessariamente su tutte le celle.
Puoi ottenere cio' confermando la formula modificata con Contr-Maiusc-Enter, che estendera' la nuova formula a tutte le celle che contenevano la formula ante-modifica.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 15732
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Integrare formula matriciale

Postdi BG66 » 14/09/18 20:38

Ciao Anthony,
avevo deciso che sbagliavo qualcosa :oops: perchè "effettuando correttamente l'operazione"ottenevo questo risultato:
Immagine.

Mentre, ovviamente, se attivo l'opzione "S" il dato atteso è la presenza del titolo del corso per una sola volta (in M21).

Gene.
BG66
Excel2010
BG66
Utente Senior
 
Post: 130
Iscritto il: 20/08/16 07:44

Re: Integrare formula matriciale

Postdi Anthony47 » 15/09/18 19:13

Perdona, non ho capito se hai risolto modificando la formula, o modificando altro, o e' ancora da risolvere.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 15732
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Integrare formula matriciale

Postdi BG66 » 16/09/18 04:12

Ciao Anthony,
purtroppo ancora no.
Modificando la formula ottengo come da immagine il ripetersi del nome dell'unità didattica per varie volte. Mentre io vorrei che ci fosse solo in M21 (ovviamente solamente quando è presente la lettera S, altrimenti và benissimo l'elenco di tutte le unità didattiche che compongono il corso).
Aspetto di capire da te se vi è soluzione "professionale" o in alternativa farò qualche tentativo con la formattazione condizionale.

Grazie per l'aiuto.
BG66
Excel2010
BG66
Utente Senior
 
Post: 130
Iscritto il: 20/08/16 07:44

Re: Integrare formula matriciale

Postdi Anthony47 » 16/09/18 19:03

Mi ero fermato al messaggio di errore e non avevo indagato sul resto del messaggio...

La formula matriciale restituisce un valore da spalmare su un' area; se il valore reso e' unico (non una matrice con un unico valore, ma proprio in unico valore) tutta l'area conterra' quel valore.

Non avendo un file di test ho lavorato sul file che pubblicasti il 7 agosto ("l'altra" discussione), e partirei dalla formula alternativa che avevo proposto nel mio secondo messaggio (viewtopic.php?f=26&t=109952#p645143)
Avrei potuto usare altre soluzioni; ad esempio
Codice: Seleziona tutto
    =INDICE(C16:O25;1;CONFRONTA($A$2;$C$14:$O$14;0))

Da inserire (col solo Enter) in A3 e poi copiare verso il basso; ma il concetto di fondo e' che calcolare 1 formula e' piu' veloce che calcolarne 10


Supponendo che il "flag" sia in B5; supponiamo che se B5 sia "S" allora si vuole visualizzare (solo) la cella E2, altrimenti si visualizza tutto il contenuto del corso.
Allora si cancella la formula matriciale in A3:A12; poi in A3 si inserisce
Codice: Seleziona tutto
=SE($B$5="S";$E$2;INDICE(C16:O25;1;CONFRONTA($A$2;$C$14:$O$14;0)))

Copia (per semplicita') A3 in A4 e poi modifica il valore da restituire se B5=S:
Codice: Seleziona tutto
=SE($B$5="S";"";INDICE(C17:O26;1;CONFRONTA($A$2;$C$14:$O$14;0)))

Copiare infine A4 verso il basso.

Le formule sono "normali" (non matriciali)

Dovrai adattare al tuo tracciato, ma credo che il concetto sia facile da capire.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 15732
Iscritto il: 21/03/06 16:03
Località: Ivrea

[RISOLTO] Integrare formula matriciale

Postdi BG66 » 16/09/18 21:13

[RISOLTO]
Ciao Anthony,
grazie mille per l'aiuto.

Allego per gli altri utenti il link al file finale:
https://www.dropbox.com/s/2b88v1ih5rt21dd/contenuto%20corsiAnthony_bis.xlsx?dl=0

Buona serata e alla prossima.
BG66
Excel2010
BG66
Utente Senior
 
Post: 130
Iscritto il: 20/08/16 07:44


Torna a Applicazioni Office Windows


Topic correlati a "Integrare formula matriciale":

Formula excel
Autore: nuvolotta
Forum: Software Windows
Risposte: 5

Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti