Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Kubuntu non mi spegne il notebook

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

Kubuntu non mi spegne il notebook

Postdi ninuzzu » 07/11/07 22:16

Salve a tutti, da quando ho installato Kubuntu 7.10 ho uno strano problema, non riesco infatti a spegnere il notebook.
Se clicco infatti su menù K e poi su spegnimento si spegne il monitor (rimane tutto nero) ma il pc rimane acceso e sono costretto a spegnerlo bruscamente utilizzando il tasto power del portatile.

gogolando ho seguito questa guida:
http://forum.ubuntu-it.org/index.php?to ... #msg867599
ma non ho ancora risolto. Mi dareste una mano?

ciao e grazie
Ciao Ciao
ninuzzu
Utente Senior
 
Post: 171
Iscritto il: 07/07/05 18:10

Sponsor
 

Postdi ninuzzu » 07/11/07 23:03

aggiornamento:
Nel forum italiano di Ubuntu ho inoltre letto questo topic: http://forum.ubuntu-it.org/index.php?topic=14220.0
mo no ho capito bene quale parametro del mio file menu.lst devo modificare, per questo ve lo posto così magari mi potrete consigliare meglio, ammesso che sia la soluzione al problema:

Codice: Seleziona tutto
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default      4

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=e7991119-9816-4f30-a9b3-5b353900167d ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,2)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash locale=it_IT

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Ubuntu 7.10, kernel 2.6.22-14-generic
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.22-14-generic root=UUID=e7991119-9816-4f30-a9b3-5b353900167d ro quiet splash locale=it_IT
initrd      /boot/initrd.img-2.6.22-14-generic
quiet

title      Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root      (hd0,2)
kernel      /boot/vmlinuz-2.6.22-14-generic root=UUID=e7991119-9816-4f30-a9b3-5b353900167d ro single
initrd      /boot/initrd.img-2.6.22-14-generic

title      Ubuntu 7.10, memtest86+
root      (hd0,2)
kernel      /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Microsoft Windows XP Home Edition
root      (hd0,0)
savedefault
makeactive
chainloader   +1



ciao e grazie
Ciao Ciao
ninuzzu
Utente Senior
 
Post: 171
Iscritto il: 07/07/05 18:10

Postdi gunter » 08/11/07 11:02

Ciao, alla fine del tuo file hai l'elenco dei vari kernel con cui eseguire il boot (e windows). Nella riga "kernel" di ognuno aggiungi "noapic" e "reboot=h" separate da uno spazio, dopo "locale...IT" .
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi ninuzzu » 16/11/07 02:08

scusa gunter ma non ho capito, devo aggiungere "noapic" "reboot=h" (senza virgolette giusto?)ad ogni riga kernel o soltanto in quella dove compare "locale...IT" , ovvero:

kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=e7991119-9816-4f30-a9b3-5b353900167d ro quiet splash locale=it_IT noapic reboot=h


:?:
Ciao Ciao
ninuzzu
Utente Senior
 
Post: 171
Iscritto il: 07/07/05 18:10

Postdi gunter » 16/11/07 09:18

A tutte le righe "kernel" esattamente come hai scritto tu... Poi devi ricordarti di aggiornare la configurazione di grub con:
Codice: Seleziona tutto
sudo update-grub

o:
Codice: Seleziona tutto
sudo grub-install /dev/nomehd
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)


Torna a Software Linux


Topic correlati a "Kubuntu non mi spegne il notebook":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti