Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

scheda ati x1600 aggiornata ma wine non va' + [RISOLTO]

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

scheda ati x1600 aggiornata ma wine non va' + [RISOLTO]

Postdi serdux » 01/11/07 17:21

Ho aggiornato da poco gli ultimi driver di ati ,il sistema ora è stabile ma wine non gira piu' .
Ho provato a disinstallarlo rimuovere le cartelle di /home/user/.wine ed installarlo di nuovo riavviando il sistema ma mi da' il segunete errore:

-----------------------
wine: creating configuration directory '/home/user/.wine'...
X Error of failed request: GLXBadContext
Major opcode of failed request: 145 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 17
Current serial number in output stream: 17 --------
-------------------------------------------------------------

ORa quando ho installato i driver ati poi ho usato questa opzione aticonfig --initial -f e mi ha creato un nuovo file dentro /etc/X/ facerndomi il backup del vecchio.
Ora puo' essere sua la copa, e poi se copio il file vecchio su X i driver ritorneranno quelli di prima oppure cambiano solo le impostazioni dello schermo tastiera e muose?.
So' che ci sono dentro X anche i driver della scheda video ma vorrei spiegarmi meglio vengono aggiornati anche loro oppure aggiorna i moduli del kernel ?.Oppure aggiorna(come credo)sia X e kernel?.

Scusate per tutte queste domande ma non ho le idee molto chiare su questo anche se e da ormai 5 anni che uso Linux.


:-? :-?
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Sponsor
 

Postdi gunter » 01/11/07 18:54

Se apri e modifichi il file /etc/X11/xorg.conf poi devi riavviare il server X (ctrl+alt+backspace) affinchè le nuove impostazioni vengano introdotte.
Inoltre i driver proprietari ati ("fglrx") non sono dentro xorg (lì trovi quelli opensource "ati" "radeon") e vengono scaricati a parte.
Quindi usare il vecchio xorg.conf cambierà alcune impostazioni, ma, a patto che fosse anche prima configurato per i driver proprietari, userà gli ultimi driver che hai scaricato...
Potresti anche confrontarli attraverso kdiff o qualche altro programma del genere... ;)

Prova a vedere se l'errore di wine scompare...
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi serdux » 02/11/07 08:32

PRoblema risolto, credo sia stata colpa del fatto che oltre ad avere installato i nuovi driver ati avevo installati anche quelli della mia distribuzione, cosi' gli ho rimossi tutti e due ed ho installato ovviamente quelli nuovi e ora sembrano funzionare.
Come ci sono arrivato dirai tu cosi':
Stamattina mi alzo con la mente freesca faccio un paio di test quindi disattivo da bios(frame 256mb lo metto in disable)imposto manulamente la frequenza di clock a 400 (come il modello precedente quindi con i driver per quella frequenza e non in auto), equi ok, dopodichè riconfiguro drakxconf e anzichè mettere i driver fglx metto fbdev(o simile)infinite reboot il tutto e vado in init 5, e li non va' iinternet(devo da root lanciare http restart)e wine non si configura dandomi l'errore che avevo scritto in precedenza,csi' passo ad init 3 e ta ta'! mi dice che i driver ati pclinux sono gia' installati, e da li mi si illumina il cervello cosi' ho disinstallato il tutto installato il driver aggiornati ati e configurato con aticonfig --initial -f(e prima riimpostasto con drakxconf non piu' fbdev ma fglx )e poi ho fatto partire startx ed ora va' tutto alla grande, sempre lento wine come in principio ma almeno non si blocca piu' il computer ed è gia' una cosa buona.

Adesso provero ' ad installare una versione wine piu' aggiornata e vedro' se il problema della lentezza persiste.

Un'ultima cosa io con winecfg devo manulamente adddizionare le d3d9 10 8 e cosi' via, non si puo' dare un comando che le copi tutte in modo da non caricarle sempre manualmente?
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Postdi serdux » 02/11/07 08:34

Ah dimenticavo ho usato kdiff3 come da te consigliato e delle differenze del file c'erano, anche se comunque non mi risolvevano il problema.
Comunque un programmino davvero niente male.

Thx
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Postdi sephiroth_88 » 25/11/07 02:40

ciao chiedo informazione su questo topic per non aprirne un altro ho istallato wine su ubuntu 7.10 ho una geforce 6150 e una scheda audio compatibile con gli standard hd volevo sapere se per istallare i driver è sufficente usare i film inf di windows o c' è una procedura particolare?
cpu: amd64x2 4400+ (2,4 ghz) - 2 gb di ram - 160x2 gb hd raid 0 geforce 8600 gt 512 mb OS: VISTA Home Premium, XP Pro, Ubuntu Server
sephiroth_88
Utente Senior
 
Post: 553
Iscritto il: 30/03/07 23:28

Postdi gunter » 25/11/07 13:23

Per caso non ti funziona qualcosa audio o video? Per installare i driver nvidia proprietari in ubuntu credo ci sia una procedura apposita guidata oppure puoi sempre scaricarli dal sito nvidia...
Non puoi usare i driver windows in linux se non per alcune schede wifi con ndiswrapper...
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)


Torna a Software Linux


Topic correlati a "scheda ati x1600 aggiornata ma wine non va' + [RISOLTO]":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti