Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

installazione wine su Ubuntu [RISOLTO]

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

installazione wine su Ubuntu [RISOLTO]

Postdi zone » 10/06/07 13:16

Ciao a tutti, da giorni stò tentando di installare wine sulla mia distro Ubuntu 6.06 Dapper DRake, ma non ci riesco.

il mio file dei repository è il seguente:
Codice: Seleziona tutto
# Ubuntu supported packages
# GPG key: 437D05B5
deb http://it.archive.ubuntu.com/ubuntu dapper main restricted
deb http://it.archive.ubuntu.com/ubuntu dapper-updates main restricted
deb http://security.ubuntu.com/ubuntu dapper-security main restricted

# Ubuntu community supported packages
# GPG key: 437D05B5
deb http://it.archive.ubuntu.com/ubuntu dapper universe multiverse
deb http://it.archive.ubuntu.com/ubuntu dapper-updates universe multiverse
deb http://security.ubuntu.com/ubuntu dapper-security universe multiverse

# Ubuntu backports project
# GPG key: 437D05B5
deb http://it.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse

deb http://wine.budgetdedicated.com/apt dapper main


da shell lancio il comando:
Codice: Seleziona tutto
apt-get install wine


ma mi dà i seguenti errori:
Codice: Seleziona tutto
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler
dire che è stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o rimossi da incoming.

Poiché è stata richiesta solo una singola operazione è molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
  wine: Dipende: libasound2 (> 1.0.12) ma 1.0.10-2ubuntu4 sta per essere installato
        Dipende: libc6 (>= 2.5-0ubuntu1) ma 2.3.6-0ubuntu20.4 sta per essere installato
        Dipende: libgcc1 (>= 1:4.1.2) ma 1:4.0.3-1ubuntu5 sta per essere installato
        Dipende: libgphoto2-2 (>= 2.3.0) ma 2.1.6-5.2ubuntu8 sta per essere installato
        Dipende: libgphoto2-port0 (>= 2.3.0) ma 2.1.6-5.2ubuntu8 sta per essere installato
        Dipende: libstdc++6 (>= 4.1.2) ma 4.0.3-1ubuntu5 sta per essere installato
        Dipende: libxml2 (>= 2.6.27) ma 2.6.24.dfsg-1ubuntu1 sta per essere installato
        Dipende: libxslt1.1 (>= 1.1.20) ma 1.1.15-1ubuntu1 sta per essere installato
E: Pacchetto non integro


tutti i pacchetti segnalati sono installati e aggiornati all'ultima versione .

Ho tentato di risolvere in questo modo, senza risultati:
Codice: Seleziona tutto
apt-get update
dpkg --force-all --configure -a
apt-get -f install
apt-get -f dist-upgrade
apt-get install wine


Spero in un vostro aiuto.
grazie
WeB HacKers TeaM - sicurezza informatica
www.methack.it
zone
Utente Junior
 
Post: 20
Iscritto il: 13/04/07 20:19

Sponsor
 

Postdi gunter » 10/06/07 13:57

Francamente non riesco a capire cosa ti stia succendendo, al di là del fatto che probabilmente non soddisfi alcune dipendenze...
Probabilmente hai seguito questa guida, però non so se hai ubuntu a 64bit in quel caso qui dice che c'è solo per feisty fawn e tentando di accedere al repo da una versione precedente apt va nel pallone e cerca pacchetti all'esterno( :eeh: )...

edit: anche nella guida su ubuntu-it dicono la stessa cosa e rimandano a questa procedura..
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi zone » 10/06/07 14:12

non sono su 64bit.
ma ho risolto. la procura di installazione di Wine su Ubuntu e Debian è leggermente diversa.

Ecco i repository corretti:

Per Ubuntu Feisty (7.04):
sudo wget http://wine.budgetdedicated.com/apt/sou ... eisty.list -O /etc/apt/sources.list.d/winehq.list

Per Ubuntu Edgy (6.10):
sudo wget http://wine.budgetdedicated.com/apt/sou ... /edgy.list -O /etc/apt/sources.list.d/winehq.list

Per Ubuntu Dapper (6.06):
sudo wget http://wine.budgetdedicated.com/apt/sou ... apper.list -O /etc/apt/sources.list.d/winehq.list

Per Debian Etch (4.0):
sudo wget http://wine.budgetdedicated.com/apt/sou ... /etch.list -O /etc/apt/sources.list.d/winehq.list

Poi, potete installare wine usando Synaptic. Oppure, potete installarlo da terminale in questo modo (con il quale ho risolto il problema):
Codice: Seleziona tutto
sudo apt-get update
sudo apt-get install wine
WeB HacKers TeaM - sicurezza informatica
www.methack.it
zone
Utente Junior
 
Post: 20
Iscritto il: 13/04/07 20:19


Torna a Software Linux


Topic correlati a "installazione wine su Ubuntu [RISOLTO]":


Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti