Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Reinstallare LILO

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

Reinstallare LILO

Postdi milter » 13/12/02 09:01

ciao..!
spero che sia il forum giusto... nel caso spostatelo pure voi... :)

Ho un pc con 2 HD fisicamente separati: sul 1° W98, sul 2° Linux Mandrake.... e fin qui tutto ok... :)
..l'altro giorno, avendo tutta una serie di problemi su W98 ho reinstallato W98 su se stesso, risolvendo tutto .....ma al successivo boot ho scoperto che era sparito LILO :cry: :cry: :cry:
...come faccio a reinstallarlo o comunque ad utilizzare linux sul 2° HD... :?:
...grazie... :!:
....ciao a tutti.......milter :)
milter
Utente Senior
 
Post: 130
Iscritto il: 07/09/01 01:00
Località: torino

Sponsor
 

Postdi Nemok » 13/12/02 16:46

Semplice:il signor windows98 è un bel prepotente (chissà come mai..... :mmmh: ) quindi sovrascrive automaticamente l'mbr.
Avvia linux con il disco di avvio che ti eri creato durante l'installazione (l'avevi creato vero??!!) e rimetti il lilo nell'mbr dando il comando:
lilo -v
da consolle (da root).
Nel 1968 la potenza operativa di 2 C-64 hanno portato un razzo sulla luna. Oggi la potenza operativa di un Athlon 4000+ viene usata per far girare Windows XP....Qualcosa deve essere andato storto....
--Powered by Debian Sid/unstable on 2.6.10--
Nemok
Utente Senior
 
Post: 1420
Iscritto il: 04/09/01 01:00
Località: Roma

Postdi s1kboy » 27/12/02 15:39

allora il mio problema è simile.

avevo un hd con 2 partizioni, su una winXP-pro, l'altra inusata.
sulla seconda poi ho installato slackware 8.1, senza problemi,
creando anche una swap partition.

però poi sotto lilo potevo solo avviare linux, se sceglievo
dos diceva qualcosa come "bootdisk failure" o qualcosa del
genere (scusate non mi riccordo). e linux cmq funzionava
alla perfezione. a questo punto ho reinstallato windows, non
sapendo ovviamente che mi cancellasse il mbr.

la situazione cioé è questa:
- ho installato winXP e linux
- posso solo avviare winXP perché lilo è stato disattivato

cosa posso fare qua?

grazie già in anticipo!! :)

ciauz
74 or 75, that's the question! or even 90?
s1kboy
Utente Junior
 
Post: 70
Iscritto il: 07/10/02 13:46
Località: Bolzano

Postdi s1kboy » 27/12/02 15:44

e l'unico bootdisk che ho è quello di windows :(
74 or 75, that's the question! or even 90?
s1kboy
Utente Junior
 
Post: 70
Iscritto il: 07/10/02 13:46
Località: Bolzano

Postdi eduardroccatello » 31/12/02 20:09

avvia col cd di slackware
avvia una sessione linux single (così sei root)
edita /etc/lilo.conf (dopo aver montato la partizione di root dove avevi installato linux) e poi lancia lilo

ciao
Eduard Roccatello
Modding, overclock and hardware reviews @ http://www.pcimprover.it
RoLUG member @ http://rovigo.linux.it
eduardroccatello
Utente Senior
 
Post: 134
Iscritto il: 09/12/02 20:06
Località: Rovigo


Torna a Software Linux


Topic correlati a "Reinstallare LILO":


Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti