Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Connesisone lenta con Mandriva: AGGIORNAMENTI!

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

Connesisone lenta con Mandriva: AGGIORNAMENTI!

Postdi skid » 05/03/07 10:07

Dunque, con Mandriva dopo 10 gg di craniate sono arrivato a questo punto: la connessione adesso va, ma è molto lenta (prima non andava affatto, solo con Kubuntu riuscivo a fare qualche cosa...)
Ho seguito i consigli postati da Gunter, ed ora i l file NETWORK in /etc/sysconfig è:
NETWORKING=yes
NETWORKING_IPV6=no

Leggendo i link sempre postati gentilmente da Gunter ho anche controllato i file eth0 ed eth1 in /etc/sysconfig/network-scripts che si presentano ora come segue:
DEVICE=eth0
BOOTPROTO=dhcp
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
ONBOOT=yes
METRIC=5
MII_NOT_SUPPORTED=no
USERCTL=no
MS_DNS1=62.94.0.1
MS_DNS2=62.94.0.2
RESOLV_MODS=yes
IPV6INIT=no
IPV6TO4INIT=no
DHCP_CLIENT=dhclient
NEEDHOSTNAME=yes
PEERDNS=no
PEERYP=no
PEERNTPD=no


ed eth1:
DEVICE=eth1
BOOTPROTO=dhcp
ONBOOT=no


e per completare Ifconfig si presenta come segue:
eth0 Link encap:Ethernet
HWaddr 00:13:D4:AA:9C:B7
inet addr:192.168.1.2
Bcast:192.168.1.255
Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:790 errors:0 dropped:0 overruns:0 frame:0
TX packets:1473 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:264665 (258.4 KiB) TX bytes:387290 (378.2 KiB)
Interrupt:22 Base address:0xdead
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2464 (2.4 KiB) TX bytes:2464 (2.4 KiB)


Resolv.con si trova così (e si vede che ho aggiunto come suggerito i DNS)

# $Id: resolv.conf,v 1.1 2006/06/02 23:25:57 othauvin Exp $
# Basic resolv.conf
# search domain
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
nameserver 62.94.0.1
nameserver 62.94.0.2


Ho anche aggiunto la dicitura IPV4.tmp_windows...(non mi ricordo non l'ho segnata) come suggerito sempre nel post di Gunter.

La cosa interessante è che aprendo i siti web con konqueror ho una indicazione sulla velocità di scaricamento dai dati.
Ed ho notato che parto a manetta, poi progressivamente scendo di velocità 200 kb/s,100kb/s,80,60,20...e poi non va più una mazza.
Il risultato è che vedo tutte le scritte apparire, e quando tocca alle immagini, rimane il quadratino con la x.
Diciamo che ogni secondo circa mi si dimezza la velocità di download...fino a fermarsi del tutto.
Da cosa può dipendere secondo voi? Premetto che Mandriva sul portatile agganciato allo stesso router fila 3 volte + veloce di winzozz...(eseguito da boot CD)
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Sponsor
 

Postdi gunter » 05/03/07 11:20

Mi sono riletto tutti i post precedenti per rifarmi l'idea del problema e cosa avevi fatto fino ad ora...
Dopo tutti questi cambiamenti e con il fatto che da liveCD tutto funzionava correttamente si necessita di un cambio di approccio al problema ;)
Potresti provare a disabilitare il dhcp (mi sembrava di aver letto che hai un router quindi devi entrare nella configurazione) e ad inserire tu stesso l'ip del pc.
esempio se il router ha indirizzo 192.168.1.1
PC(mandriva):
ip: 192.168.1.2
subnet mask: 255.255.255.0
gateway e dns: 192.168.1.1

Speriamo che funzioni ;)
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi skid » 05/03/07 12:19

Come mai devo impostare i DNS a 192.168.1.1 ?
Non devo quindi usare quelli del Provider? 68.94.0.1/2
Grazie!
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Postdi gunter » 05/03/07 14:23

Beh innanzitutto dovresti dirmi se funziona...per l'impostazione del dns con l'indirizzo del router è una possibilità(così lasci che sia lui stesso a preoccuparsene)...
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi skid » 06/03/07 21:41

Nel frattempo se avete voglia date un occhiata a questo file.txt (seguire il link sotto) generato da uno script che mi ha girato un tizio beccato su Google/gruppi/mandriva.os group.
C'è vita morte e miracoli dei settings...
magari vi viene in mente qualche idea.
Nel frattempo tra stanotte e domani notte faccio un tentativo con IP fisso.
sciao!

LINK : http://www.jokabsafety.191.it/docs/dosa.txt
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Postdi gunter » 07/03/07 00:06

Ho letto (sommariamente) il file...non so c'è qualcosa che non va ma questo mi rende perplesso:
skid ha scritto:...Fino a quando girava da CD, Mandriva e la rete si comportavano benissimo (via cavo per il momento)...

Bisognerebbe capire cosa cambia dal cd live all'installazione per la scheda di rete...comunque intanto prova con la rete ad ip statici e dicci i risultati poi vediamo...
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi skid » 10/03/07 15:29

Signori......problema individuato!!!!
Sto postando usando linux, e va che è una bellezza.
Come? Semplicemente disabilitando dal bios la scheda lan SIS190 integrata nella motherboard, e utilizzando una scheda di rete PCI.

Ora la cosa è fissata: sembra proprio un problema di compatibilità fra linux e la scheda di rete integrata.
Esiste secondo voi un modo per risolvere il problema?
Un upgrade della bios può servire ?

Bye...
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Postdi gunter » 12/03/07 10:06

Non mi ricordo la tua scheda madre di che tipo era, comunque continuando a googlare in tanti siti parlano di andarsi a prendere dei driver da altri kernel e via di ricompilazione...se hai una scheda asus prova a vedere se c'è qualche driver da scaricare sul sito della asus in modo da sostituire quello del kernel...
Mi dispiace è l'unica cosa che sono riuscito a trovare...
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi skid » 12/03/07 22:01

effettivamente un driver di aggiornamento ci sarebbe pure.
Il solito problema è che è un .exe autoinstallante...non so se riesco a cavare fuori il .sys, e comunque non c'è una finestar che mi ocnsente di aggiornare il driver della scheda lan in Madriva...oppure non l'ho vista io.
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Postdi ivo » 21/03/07 13:44

se non erro, utilizzando il pcmando ndswrapper si riesce a caricare un driver winzoz su linux.
Nel hanno parlato, gli sesperti, in una delle utlime newsletter
Immagine
Avatar utente
ivo
Utente Senior
 
Post: 1134
Iscritto il: 20/08/01 01:00
Località: Treviso

Postdi gunter » 21/03/07 15:17

come dice ivo basta trattare il file .exe come se fosse un archivio poi con ndiswrapper dovresti riuscirci...mi dispiace non aver visto prima il post....
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)


Torna a Software Linux


Topic correlati a "Connesisone lenta con Mandriva: AGGIORNAMENTI!":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti