Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

problema con codifica caratteri linux<-->windows

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

problema con codifica caratteri linux<-->windows

Postdi Bucaniere » 22/12/06 00:24

Ho un problema di codifica caratteri, e spero qualcuno mi possa aiutare a risolverlo...
La situazione è questa:
ho come sistema di default ubuntu 6.10, e xp come secondo sistema operativo. Tutte le partizioni sono in ext3 a parte quella di xp che è in ntfs (ho messo il driver in xp per avere accesso completo a ext3).
Il problema sorge con i caratteri accentati, che sotto linux vedo come dei punti interrogativi, li correggo, ma quando passo a xp vedo con caratteri strani, tipo "├Â" o altro. Li correggo sotto xp, ma quando passo a linux li vedo nuovamente come punti interrogativi. Purtroppo avrei necessità di risolvere questo problema, il programma per caricare i miei audiolibri mp3 sul mio lettore sony non gira sotto linux (maledetta sony :evil: ) e anche per altri programmi mi tocca ancora usare win...
Ho fatto un po' di ricerche, ed ho capito che il problema risiede nella codifica caratteri dei due sistemi operativi: UTF-8 per linux e CP850 per ntfs windows.
Domanda: esiste un modo per risolvere questo problema senza ogni volta rinominarmi i files? Posso cambiare la codifica caratteri del sistema operativo? (linux con CP850 o ISO 8859-1 mi andrebbe anche benissimo)
Avatar utente
Bucaniere
Utente Junior
 
Post: 33
Iscritto il: 26/01/04 11:44
Località: Sondrio

Sponsor
 

Postdi zello » 23/12/06 14:42

Ma in /etc/fstab, riga relativa alla partizione ntfs, specifichi il codepage da usare?
Dal mio /etc/fstab
Codice: Seleziona tutto
/dev/hda1 /mnt/nt ntfs nls=iso8859-15,ro,user,exec,gid=100,umask=007 0 0
Il faut être toujours ivre. Tout est là : c'est l'unique question. Pour ne pas sentir l'horrible fardeau du Temps qui brise vos épaules et vous penche vers la terre,il faut vous enivrer sans trêve...
Avatar utente
zello
Moderatore
 
Post: 2351
Iscritto il: 06/05/02 13:44

Postdi Bucaniere » 25/12/06 00:08

purtroppo il problema si verifica in win, più che in linux... :roll:
La partizione dove ho i file in questione è un ext3 condiviso anche da win (ho installato il driver per il completo supporto), il problema mi pare di capire che è nella codifica caratteri del sistema operativo.
In ogni caso, il mio fstab è questo:
Codice: Seleziona tutto
# /dev/sda2 (Ubuntu)
UUID=de227d94-a764-46c0-802d-fe86e76c5003 /               ext3    defaults,errors=remount-ro 0       1
#
# /dev/sda1 (Eva)
UUID=6AC1F425FF4780EB /media/Eva      ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
#
# /dev/sdb1 (Exter)
UUID=797fee8b-ef38-4223-a515-09df5cb91b09 /media/Exter    ext3    defaults        0       2
#
# /dev/sdc1 (Linux)
UUID=c2b9c5c3-7d8b-4cd4-be10-98a2e3320139 /media/Linux    ext3    defaults        0       2
#
# /dev/sda3 (Swap)
UUID=2da56226-9a74-4e9b-8de6-deca18cf4a94 none            swap    sw              0       0
#
/dev/hdb        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/           /media/floppy0  auto    rw,user,noauto  0       0

I problemi di cui parlo si riferiscono alla partizione sdc1...
Ora in linux li vedo perfettamente, ma quando passo a win è un casino... e se li correggo in win non li vedo bene in linux... :aaah
Sto cercando il sistema di cambiare la codifica caratteri di linux (su win manco ci provo), se hai qualche idea, è bene accetta!
Ma mi sembra strano che sia solo io ad avere sto problema, tutti dicono che hanno problemi simili ma non ne trovo la soluzione! :mmmh:
Avatar utente
Bucaniere
Utente Junior
 
Post: 33
Iscritto il: 26/01/04 11:44
Località: Sondrio


Torna a Software Linux


Topic correlati a "problema con codifica caratteri linux<-->windows":

Problema Windows 10
Autore: asso1998
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti