Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

maledetto euro!

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

maledetto euro!

Postdi berto81 » 03/09/02 20:55

Il simbolo dell'euro mi sta dando un po' di problemi...
Uso la mandrake 8.1 e kde 2.2.1, impostato con lingua italiana e set di caratteri ISO-8859-15.

Vorrei capire come mai non riesco a digitare il simbolo nelle applicazioni KDE, X e nella console; mentre se copio il carattere in klipper (da una pagina web o da openoffice) e lo incollo, funziona perfettamente (almeno nella konsole e in kedit).
AltGr+e funziona solo in openoffice.

Inoltre Mozilla e Opera visualizzano correttamente il simbolo, mentre konqueror non lo mostra nemmeno (si vede come uno spazio) nonostante sia impostato sullo stesso set di caratteri.
Se incollo il simbolo da klipper qua (sto usando Opera), esce un ? .
Ho cercato sui newsgoup con google ma non ho trovato una risposta chiara e definitiva.

Non riesco nemmeno a capire a quale livello sia il problema: layout di tastiera? font di X11? kde?

Se qualcuno ha qualche suggerimento si faccia avanti!
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47

Sponsor
 

Postdi berto81 » 03/09/02 22:02

ho applicato alcuni suggerimenti trovati in giro, per esempio qua:
http://www.koffice.org/kword/euro.phtml

consultando questa pagina ho potuto vedere che almeno in teoria il mio sistema è già configurato per l'euro.

questi sono i comandi che ho usato (in una shell aperta sotto kde), e i loro output:

$ xmodmap
xmodmap: up to 2 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x6d)
mod1 Alt_L (0x40)
mod2 Num_Lock (0x4d)
mod3 Mode_switch (0x71)
mod4
mod5 Scroll_Lock (0x4e)

$ xmodmap -pke | grep -w 26
keycode 26 = e E EuroSign cent

Ma tutto rimane come prima, anche ripetendo:

$ xmodmap - e 'keycode 26 = e E EuroSign'

Il simbolo euro, copiato da opera, poi incollato e salvato in un file di testo, viene successivamente visualizzato perfettamente, anche senza avviare X.
(quindi, lasciando perdere kde e considerando solo il fatto che non riesco a scriverlo, non è un problema di font... o no?).

Ho notato che invece il simbolo del cent ¢ funziona (AltGR-E).

Ne ho dedotto che a "non andare" è EuroSign. infatti se faccio:

$ xmodmap -e 'keycode 26 = e E A cent'

premendo altgr-e mi esce la A !!!

non ci capisco più niente...

:(
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47

Postdi berto81 » 04/09/02 13:42

ecco l'ennesima puntata della vicenda... scusate se sono noiso ma magari a qualcuno può interessare.

in kde ho impostato come carattere "generale" e "grandezza fissa" il Verdana 8859-15.
Altri font non hanno questo charset, ma solo "predefinito" (intende 8859-1?)
e ISO-10646-1.

precedentemente ho editato i file i18n e keyboard in /etc/sysconfig seguendo dei consigli trovati in rete, e riavviato.
riporto il contenuto attuale dei 2 files.

/etc/sysconfig/i18n:

SYSFONT=lat0-sun16
LC_MONETARY=it_IT@euro
LC_CTYPE=it_IT@euro
LC_NUMERIC=it_IT@euro
LC_MESSAGES=it_IT@euro
LANGUAGE=it_IT@euro
LC_TIME=it_IT@euro
LC_COLLATE=it_IT@euro
SYSFONTACM=iso15
LANG=it_IT@euro

/etc/sysconfig/keyboard:

KBCHARSET=iso-8859-15
DISABLE_WINDOWS_KEY=no
BACKSPACE=Delete
KEYTABLE=it-latin1

in i18n prima c'era LANG=it

ora l'euro continua ad essere visualizzato correttamente in tutte le applicazioni tranne konqueror, che però fa correttamente l'anteprima di files di testo con l'euro, forse sono le pagine web che gli impongono font che non lo supportano.
incollando il simbolo in qualsiasi applicazione o nella console, viene visualizzato correttamente.
se lo incollo qua mi esce un ?

facendo altgr-e:
in kedit e qua mi esce uno strano simbolo: ¤
nella console mi esce ?
in amsn (un programmino di messenger per X) e gedit mi esce l'euro! :eeh:

il cent ¢ (altgr-E) funziona ancora dappertutto.

alla prossima... :roll:
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47


Torna a Software Linux


Topic correlati a "maledetto euro!":


Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti