Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Server di posta Postfix Interno...

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

Server di posta Postfix Interno...

Postdi Eniac » 26/03/05 16:09

ciao a tutti.

Ho un problema sicuramente di facile soluzione per voi ;)

Ho necessità di installare un server di posta interno ad una piccola aula di computer ( 12 PC); questo server deve solo gestire lo scambio di e-mail fra i computer della LAN, non deve mettersi in comunicazione con l'esterno e quindi con Internet.

Ricapitolando, deve solo inviare e recapitere le e-mail di 12 pc presenti in una piccolissima LAN di 12 PC e basta. ( E' comunque una specie di prova, esempio temporaneo niente di permanente)

Credo sia una cosa molto semplice.

Ho optato per utilizzare Postfix, come server di posta.

A questo scopo ho installato su un pc la Suse 8.2 con Postfix e altri servizi installati.

Questa è la configurazione del mio server:

nome host: fox
nome dominio: locale.it

tipologia della rete sulla quale devo operare: 192.168.1.0 / 255.255.255.0
Il mio server ha indirizzo Ip: 192.168.1.155

Il problema principale è la configurazione del server.

Ho aperto il file /etc/postfix/main.cf
Vi riporto di seguito le parti che ho modificato, prese proprio dal file in questione:
---------------------------------------------------------------------------------

default_privs = nobody

# INTERNET HOST AND DOMAIN NAMES
#
# The myhostname parameter specifies the internet hostname of this
# mail system. The default is to use the fully-qualified domain name
# from gethostname(). $myhostname is used as a default value for many
# other configuration parameters.
#
#myhostname = host.domain.tld
#myhostname = virtual.domain.tld
myhostname = fox.locale.it

# The mydomain parameter specifies the local internet domain name.
# The default is to use $myhostname minus the first component.
# $mydomain is used as a default value for many other configuration
# parameters.
#
mydomain = domain.tld

# RECEIVING MAIL

inet_interfaces = all
#inet_interfaces = $myhostname
#inet_interfaces = $myhostname, localhost

# See also below, section "REJECTING MAIL FOR UNKNOWN LOCAL USERS".
#
#mydestination = $myhostname, localhost.$mydomain
#mydestination = $myhostname, localhost.$mydomain $mydomain
mydestination = $myhostname, localhost.$mydomain, $mydomain,
mail.$mydomain, http://www.$mydomain, ftp.$mydomain


# TRUST AND RELAY CONTROL
mynetworks = 192.168.1.0/24, 127.0.0.0/8
#mynetworks = $config_directory/mynetworks
#mynetworks = hash:/etc/postfix/network_table


# DELIVERY TO MAILBOX
# The mail_spool_directory parameter specifies the directory where
# UNIX-style mailboxes are kept. The default setting depends on the
# system type.
#
#mail_spool_directory = /var/mail
mail_spool_directory = /var/spool/mail

# IF YOU USE THIS TO DELIVER MAIL SYSTEM-WIDE, YOU MUST SET UP AN
# ALIAS THAT FORWARDS MAIL FOR ROOT TO A REAL USER.
#
mailbox_command = /usr/bin/procmail
#mailbox_command = /some/where/procmail -a "$EXTENSION"

alla fine del file, ho rimesso il # alle rispettive voci già modificate precedentemente.

( questa configurazione, e altre, mi sono state insegnate durante un breve corso, solo che ormai dopo mesi di inattività su linux, ho perso i colpi :cry:.)

Secondo quanto mi ricordo seguendo questa configurazione il server è pronto.

seguendo dei vecchi appunti riguardo questo argomento, ho effettuato anche queste ulteriori operazioni:

- ho riavviato il server Postfix, in modo che prendesse le mie nuove impostazioni

- ho attivato anche il server "inetd"

- ho aperto il file /etc/inetd.conf

e ho attivato, quindi tolto il cancelletto, aal'ultima voce presente nella sezione "pop et all"
( purtroppo non posso essere più preciso, poichè al momento mi trovo su un pc diverso da quello con cui devo lavorare)

con questa operazione in teoria divrei aver attivato il server "qpopper"

- sono entrato nell'editor dei runlevels e ho fatto in modo che Postfix e Inetd, partissero automaticamente all'avvio del pc.

- ho quindi creato un utente nuovo, come prova per testare il server:

username: mario.rossi
password: colore

Per quanto riguarda la configurazione del server Postfix, non mi sembra ci sia altro da fare, dato che non deve dialogare all'esterno con altri server di posta o uscire in Internet.

L'unica cosa che ho volontariamente saltato è stata la creazione degli "Aliases", nel file /etc/aliases:
secondo i miei appunti ( magari sono completamente sbagliati :P )
nel caso in cui i nomi utente sono poco chiari, o comunque scomodi per essere utilizzati come username delle e-mail, è possibile sfruttare gli aliases:
ES: "marros" potrebbe diventare "mario.rossi" ( cosa che non ho fatto)

_______________________________________________

Ora l'ultimo dubbio riguarda la configurazione dei singoli Pc.

I Pc della rete LAN utilizzeranno S.O Windows XP SP2, e come client di posta, Outlook Express

io ho fatto una prova e ho configurato il client come segue:

- indirizzo e-mail: mario.rossi@locale.it
- indirzzo server SMTP e POP3 : 192.168.1.155
cioè quello della mio server.


quando tento di scaricare la posta o comunque di collegarmi, dopo aver immesso la password dell'utente, mi ritorna errore, dicendo che la comunicazione è stata interotta. o che comunque non è possibile stabilire una connessione.

I Pc dell'aula vedono il mio server ( ping 192.168.1.155)

Non riesco a capire dove sbaglio; sicuramente è la configurazione del server, ma dopo mesi di inattività su questi argomenti, non risco più a trovare una soluzione.
Il bello che cose di questo tipo le ho già fatte, e anche un poco più complesse :-? :oops:

Chiedo a qualche anima buona se può darmi qualche dritta ;)

chiedo scusa per la lunghezza, ma ho pensato di fornire il maggio numero di informazioni possibile.

Ringrazio in anticipo chiunque mi risponda

Ciao a tutti.
[/b]
Eniac
Utente Junior
 
Post: 67
Iscritto il: 11/05/04 10:52

Sponsor
 

Postdi disgrazia » 28/03/05 15:17

Ciao! Così su due piedi l'unico errore che vedo è questo:
# The mydomain parameter specifies the local internet domain name.
# The default is to use $myhostname minus the first component.
# $mydomain is used as a default value for many other configuration
# parameters.
#
mydomain = domain.tld

Prova a commentare la riga in rosso col solito cancelletto, il valore di default va bene mentre quello specificato è sbagliato. In alternativa puoi specificarlo tu a mano:
mydomain = locale.it

Per la configurazione del server POP3 purtroppo non conosco qpopper... l'unico suggerimento che ti posso dare è di controllare che postfix e qpopper utilizzino mailbox nello stesso formato e con la stessa locazione, spesso è una cosa che è necessario configurare a mano.
disgrazia
Download Admin
 
Post: 708
Iscritto il: 08/07/02 22:16


Torna a Software Linux


Topic correlati a "Server di posta Postfix Interno...":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti