Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

non riesco a compilare nessun software!

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

non riesco a compilare nessun software!

Postdi caladio » 04/03/05 18:18

Ho MDK 10.0 ed ogni volta che scompatto un file in cartella e cerco di lanciare dal terminale il comando ./configure mi dà una serie di scritte ma alla fine dà l'errore:
"no acceptable C compiler found in $PATH" o roba simile ... come devo fare? :undecided:
caladio
caladio
Utente Senior
 
Post: 506
Iscritto il: 11/02/02 01:00
Località: italia

Sponsor
 

Postdi Nicola » 04/03/05 21:56

Installa gli strumenti di sviluppo, nello specifico gcc e make.

In Mandrake dovrebbe essere possibile dal Mandrake Control Center.
Nicola
Nicola
Utente Senior
 
Post: 7381
Iscritto il: 08/02/02 01:00

Postdi caladio » 07/03/05 14:21

Nicola ha scritto:Installa gli strumenti di sviluppo, nello specifico gcc e make.

In Mandrake dovrebbe essere possibile dal Mandrake Control Center.

ok ci proverò, grazie ;)
p.s.cmq è strano che non li installi di suo no??in fondo senza quelli molti programmi non possono essere installati :?:
caladio
caladio
Utente Senior
 
Post: 506
Iscritto il: 11/02/02 01:00
Località: italia

Postdi caladio » 08/03/05 18:52

Nicola ha scritto:Installa gli strumenti di sviluppo, nello specifico gcc e make.

In Mandrake dovrebbe essere possibile dal Mandrake Control Center.

ci ho provato ma non ci riesco perchè mi chiede di inserire il CD 4 che non ho :-?
caladio
caladio
Utente Senior
 
Post: 506
Iscritto il: 11/02/02 01:00
Località: italia

Postdi Nicola » 08/03/05 20:43

Se ricordo bene, in Mandrake 10.0 il CD4 e' solo per gli utenti iscritti al club.

Puoi comunque installare gcc,make,automake e autoconf scaricandoli da questi indirizzi e mettendoli in una cartella (puoi masterizzarli o metterli in un'unita' fat32/ntfs di windows).

ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... k.i586.rpm
ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... k.i586.rpm
ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... k.i586.rpm
ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... noarch.rpm
ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... noarch.rpm

Da un terminale con i privilegi di superutente (root) entra nella directory con cd /path/to/directory e fai:

Codice: Seleziona tutto
rpm -ivh *.rpm


Se dovessero riscontrare degli errori riportali.

Ciao
Nicola
Nicola
Utente Senior
 
Post: 7381
Iscritto il: 08/02/02 01:00

Postdi caladio » 09/03/05 19:05

Nicola ha scritto:Se ricordo bene, in Mandrake 10.0 il CD4 e' solo per gli utenti iscritti al club.

Puoi comunque installare gcc,make,automake e autoconf scaricandoli da questi indirizzi e mettendoli in una cartella (puoi masterizzarli o metterli in un'unita' fat32/ntfs di windows).

ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... k.i586.rpm
ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... k.i586.rpm
ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... k.i586.rpm
ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... noarch.rpm
ftp://ftp.ndlug.nd.edu/pub/Mandrakelinu ... noarch.rpm

Da un terminale con i privilegi di superutente (root) entra nella directory con cd /path/to/directory e fai:

Codice: Seleziona tutto
rpm -ivh *.rpm


Se dovessero riscontrare degli errori riportali.

Ciao
lo ho scaricati, stasera ci provo e domani ti dico, grazie!!! :)
caladio
caladio
Utente Senior
 
Post: 506
Iscritto il: 11/02/02 01:00
Località: italia

Postdi caladio » 10/03/05 15:47

niente mi dà questo errore:
[root@pc Prova]# rpm -ivh *.rpm
warning: autoconf2.5-2.59-3mdk.noarch.rpm: V3 DSA signature: NOKEY, key ID 26752624
error: Failed dependencies:
gcc-cpp = 3.3.2-9mdk is needed by gcc-3.3.2-9mdk
libgcc >= 3.3.2-9mdk is needed by gcc-3.3.2-9mdk
glibc-devel >= 2.2.5-14mdk is needed by gcc-3.3.2-9mdk



Se vuoi posso incollare anche il file config.log :roll:
caladio
caladio
Utente Senior
 
Post: 506
Iscritto il: 11/02/02 01:00
Località: italia

Postdi stars » 18/03/05 17:58

anke io ho mdk...io ho installato alcuni programmi con il comando urpmi nomefile..da shell...ha sempre funzionato bene...magari prima installa altre librerie dai cd..quando ho installato mdk il cd4 nn l'avevo e nell'installazione ho scelto l'opzione3cd..magari è x qllo ke t chiede il4.. ;)
stars
Utente Junior
 
Post: 34
Iscritto il: 07/03/05 10:07


Torna a Software Linux


Topic correlati a "non riesco a compilare nessun software!":


Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti