Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Proxy server su Linux

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

Proxy server su Linux

Postdi astronomer » 07/11/04 15:10

Vorrei fare condividere la connessione a internet che ho su un PC con linux, in pratica dovrei configurare un proxy server su linux.
Questa è la situazione:
PC1: SO Linux con connessione a internet
PC2: SO Windows che vuole sfruttare la connssione del PC1.
I due PC sono connessi in rete.
Grazie.
Non è la fame ma è l'ignoranza che uccide! (Litfiba)
astronomer
Utente Junior
 
Post: 96
Iscritto il: 14/02/02 01:00
Località: Torino

Sponsor
 

Postdi hexen » 07/11/04 15:37

puoi pure creare un gateway linux, ma nn chiedermi come che sono 3 mesi che ci provo io senza successo :evil: :D
hexen
Utente Senior
 
Post: 1340
Iscritto il: 15/07/02 11:10

Postdi zendune » 07/11/04 16:39

Più che un proxy server, ti serve un gateway/router + firewall (non fa mai male e Linux è il massimo).
Potete vedere il link
http://www.pc-facile.com/forum/viewtopic.php?t=23830
Dove spiego come fare sotto Linux, dovere riadattare un po', comunque cio si vede qui in caso di necessità.
Per hexen: dove è la difficoltà ?
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi hexen » 07/11/04 17:03

ho fatto quello che è scritto nel topic che hai linkato ma nn riesco a sfruttare la connessione da un client windows... e meno male che windows dovebbe essere piu semplice....
nonostante abbia messo i dsn nn mi risolve i nomi e nei ping agli ip scadono le richieste :-?
hexen
Utente Senior
 
Post: 1340
Iscritto il: 15/07/02 11:10

Postdi zendune » 07/11/04 17:05

Il ping tra le due macchine funziona (in entrambe le direzioni) ?
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia


Postdi zendune » 07/11/04 17:20

Bene, il problema non è a livello hardware.
La tua connessione è attiva quando cerchi di navigare con win ? Ovvero con Linux funziona ?
Hai indicato al client windows l'indirizzo del gateway ? Ovvero l'indirizzo ip della scheda di rete della macchina Linux ?
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi hexen » 07/11/04 18:21

il gateway mi è andato solo una volta, da allora su win nn ho cambiato la configurazione e non va piu :-?
hexen
Utente Senior
 
Post: 1340
Iscritto il: 15/07/02 11:10

Postdi zendune » 07/11/04 18:29

Il comando sotto Linux
route -n
che di dà ?
E sotto windows
ipconfig /all
che dà ?
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi zendune » 07/11/04 18:32

Dimenticavo
iptables -L
?
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi hexen » 07/11/04 18:43

Codice: Seleziona tutto
iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         
ACCEPT     all  --  192.168.0.0/24       anywhere           
DROP       all  --  anywhere             anywhere           
ACCEPT     all  --  anywhere             192.168.0.0/24     
ACCEPT     all  --  192.168.0.0/24       anywhere           

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination 


Codice: Seleziona tutto
route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.100.1   0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       127.0.0.1       255.0.0.0       UG    0      0        0 lo
0.0.0.0         192.168.100.1   0.0.0.0         UG    0      0        0 ppp0


ipconfig /all lo faccio appena mi trovo :)
hexen
Utente Senior
 
Post: 1340
Iscritto il: 15/07/02 11:10

Postdi zendune » 07/11/04 18:58

192.168.0.0 non può essere usato, devi usare 192.168.0.1 (il 192.168.0.0 perché indica per convenzione l'intera rete e 192.168.0.254 per convenzione indica di inviare il pacchetto a tutti gli host della rete).
Prova a modificare l'indirizzo di eth0 (e quindi anche sul client win).
Azzera le catene di forward
iptables -F FORWARD
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi hexen » 07/11/04 19:05

gli ip li ho assegnati bene, 192.168.0.1 al gateway e 192.168.0.2 al client
hexen
Utente Senior
 
Post: 1340
Iscritto il: 15/07/02 11:10

Postdi zendune » 07/11/04 20:23

Hai ragione ! Sto fondendo (quando si fanno più cose).
Allora due sono le cose non chiare dal comando route:
1. le due indicazioni uguali sull'indirizzo 192.168.0.0 (ne basterebbe una);
2. interfaccia di loopback (127.0.0.1) ha il flag attivo UG ovvero con l'indicazione che è l'indirizzo di gateway.
La riga corretta nella tabella di route dovrebbe essere la seguente
127.0.0.0 0.0.0.0 255.0.0.0 U lo
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi disgrazia » 07/11/04 22:56

hexen ha scritto:
Codice: Seleziona tutto
Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         
ACCEPT     all  --  192.168.0.0/24       anywhere           
DROP       all  --  anywhere             anywhere           
ACCEPT     all  --  anywhere             192.168.0.0/24     
ACCEPT     all  --  192.168.0.0/24       anywhere           



Prova a togliere la riga
Codice: Seleziona tutto
DROP       all  --  anywhere             anywhere
e per ottenere la stessa funzione cambia la policy della Chain in DROP.
Del resto se non ricordo male le regole vengono lette sequenzialemente, quindi le ultime due non vengono mai valutate.

Ah, okkio che a me è capitato in una situazione simile (ROUTER<-->GW<-->LAN) di scoprire che in realtà non potevo impostare per il router ADSL il routing verso la LAN , in poche parole il router poteva raggiungere solo le macchine sulla sua sottorete (cioè il GW), ma non c'era modo di dirgli che per raggiungere i PC in LAN si doveva passare per il GW. Sono stato costretto ad attivare il masquerading sul GW.
disgrazia
Download Admin
 
Post: 708
Iscritto il: 08/07/02 22:16

Postdi zendune » 07/11/04 23:01

Per l'ultimo punto hai ragione: se ha seguito il link, prevede anche il mascheramento della sotto rete.
Per le regole, un azzeramento (momentaneo) permette di verificare che il transito non sia fermato dal filtro.
Rimane strano comunque la presenza di due gateway (lo ed ppp0) come indicato dai flags UG.
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi Beppe » 08/11/04 17:23

Se può essere utile, avevo scritto un piccola guida per il pluto.linux.it un po di tempo fa !

La trovi su http://www.bpnets.org/index.php?page=1065014580

Ciao
Beppe
Powered by *^* D€bi@N Woody 3.0 *^*
Register User #270393 - http://counter.li.org
Beppe
Utente Senior
 
Post: 148
Iscritto il: 21/11/01 01:00


Torna a Software Linux


Topic correlati a "Proxy server su Linux":

audio audacity su linux
Autore: beppino
Forum: Software Linux
Risposte: 2

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti