Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

librerie mancanti(?)

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

librerie mancanti(?)

Postdi Luva » 12/08/03 09:28

Salve a tutti, ho un problema un po strano...
Quando tento di far partire per esempio samba, mi viene fuori questo errore:

smbd: error while loading shared libraries: libssl.so.0.9.6: cannot open shared object file: No such file or directory

al che ho controllato se le avevo (dovevo averle, samba è sempre funzionato fino ad oggi), le avevo, e le ho rinstallate...solo che sia prima che adesso ho notato che la versione era la 0.9.7. :-I

L'ultima cosa che avevo fatto era installare cups (magari è stato questo che ha dato prioblemi)...sn andato in usr/lib e c'era una cosa strana:

[root@pingui lib]§ ls libssl* -la
-rw-r--r-- 1 root root 291764 Mar 11 19:54 libssl.a
lrwxrwxrwx 1 root root 11 Aug 11 10:58 libssl.so -> libssl.so.0
lrwxrwxrwx 1 root root 15 Aug 11 10:58 libssl.so.0 -> libssl.so.0.9.7
-r-xr-xr-x 1 root root 196592 Mar 11 19:54 libssl.so.0.9.7

perchè questi collegamenti?
c'è qualcosa di sbagliato?
cosa devo fare per farlo andare?avevo pensato di rinominare il file libssl.so.0 in libssl.so.0.9.6 boh....

ciao e grazie

PS: quel giorno mi ha dato problemi di hd, fsck ha trovato errori...può essere quello la causa?
Linux Slackware 10.x - Kernel 2.6.10-gX
- - - [ http://b4yzone.altervista.org ] - - -
Luva
Utente Senior
 
Post: 397
Iscritto il: 15/07/02 19:53
Località: Pavia

Sponsor
 

Postdi zello » 12/08/03 10:21

I collegamenti sono ok, servono a far aprire ai programmi libssl indipendentemente dalla versione.
Secondo me cups ti ha semplicemente upgradato libssl dalla 0.9.6 alla 0.9.7.

Dato che è successo anche a me (per Spamassassin), ti dico che un buon modo per uscirne è pescare da qualche parte il src.rpm di samba, e ricompilarlo sul tuo sistema.
Di solito questo aggiorna le varie dipendenze.

Ciao.
Il faut être toujours ivre. Tout est là : c'est l'unique question. Pour ne pas sentir l'horrible fardeau du Temps qui brise vos épaules et vous penche vers la terre,il faut vous enivrer sans trêve...
Avatar utente
zello
Moderatore
 
Post: 2351
Iscritto il: 06/05/02 13:44

Postdi Nicola » 12/08/03 12:33

ma un rpm non prevede directory di sistema diverse rispetto a Slack che e` *BSD based ?
Nicola
Nicola
Utente Senior
 
Post: 7381
Iscritto il: 08/02/02 01:00

Postdi Luva » 12/08/03 14:17

io ho guardato nei pacchetti e la versione 0.9.7 mi sa che ce l'avevo gia... infatti open ssl è nella versione 0.9.7....boh...prima andava tutto...nn saprei cosa fare...
nn devo rinominare il file come ho detto sopra?
ciao ciao
Linux Slackware 10.x - Kernel 2.6.10-gX
- - - [ http://b4yzone.altervista.org ] - - -
Luva
Utente Senior
 
Post: 397
Iscritto il: 15/07/02 19:53
Località: Pavia

Postdi Luva » 13/08/03 10:38

ho provato a fare ldd cupsd e ldd smbd e entrambi cercano la versione 0.9.6....
non capisco perchè nella distro c'è la 0.9.7 e perchè prima andava tutto...
aiuto
Linux Slackware 10.x - Kernel 2.6.10-gX
- - - [ http://b4yzone.altervista.org ] - - -
Luva
Utente Senior
 
Post: 397
Iscritto il: 15/07/02 19:53
Località: Pavia

Postdi zello » 13/08/03 12:50

Ti ripeto: io ricompilerei i sorgenti (peschi il src.rpm e lo ricompili, è roba da cinque minuti). Di solito questo risolve i problemi di versione (a patto che la 7 sia compatibile all'indietro con la 6).
Alternativamente trovati la 6 e piazzala in usr/lib, senza rifare i vari symlinks, e vedi cosa succede.
Il faut être toujours ivre. Tout est là : c'est l'unique question. Pour ne pas sentir l'horrible fardeau du Temps qui brise vos épaules et vous penche vers la terre,il faut vous enivrer sans trêve...
Avatar utente
zello
Moderatore
 
Post: 2351
Iscritto il: 06/05/02 13:44

Postdi Luva » 13/08/03 13:21

ok..provo ad installare anche la versione 6...
grazie
Linux Slackware 10.x - Kernel 2.6.10-gX
- - - [ http://b4yzone.altervista.org ] - - -
Luva
Utente Senior
 
Post: 397
Iscritto il: 15/07/02 19:53
Località: Pavia

Postdi Luva » 19/08/03 18:08

ho un altro problema ad un'altra libreria. Se faccio partire ghostscript mi da questo errore:

[root@pingui etc]§ gs
gs: error while loading shared libraries: libXt.so.6: cannot open shared object file: No such file or directory
[root@pingui etc]§

che libreria è libXt.so.6?
ciao e grazie a tutti
Linux Slackware 10.x - Kernel 2.6.10-gX
- - - [ http://b4yzone.altervista.org ] - - -
Luva
Utente Senior
 
Post: 397
Iscritto il: 15/07/02 19:53
Località: Pavia

Postdi zello » 19/08/03 22:04

Codice: Seleziona tutto
[zello@zello lib]$ pwd
/usr/X11R6/lib
[zello@zello lib]$ rpm -qf libXt.so.6
XFree86-libs-4.2.1-3mdk


Ciao
Il faut être toujours ivre. Tout est là : c'est l'unique question. Pour ne pas sentir l'horrible fardeau du Temps qui brise vos épaules et vous penche vers la terre,il faut vous enivrer sans trêve...
Avatar utente
zello
Moderatore
 
Post: 2351
Iscritto il: 06/05/02 13:44


Torna a Software Linux


Topic correlati a "librerie mancanti(?)":


Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti