Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Combinare SOMMA.PIU.SE e INDIRETTO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Combinare SOMMA.PIU.SE e INDIRETTO

Postdi Spartacus85 » 04/08/13 13:56

Ciao Ragazzi,

ho un piccolo problema con una formula.

Se provo la seguente formula questa funziona:

Codice: Seleziona tutto
=SOMMA.PIÙ.SE(INDIRETTO(""&$A2&"!C:C"),INDIRETTO(""&$A2&"!A:A"),"Italia")


dove in A2 c'e il nome del foglio in cui cercare, nella colonna C gli elementi da sommare e in A:A la condizione da ricercare. In questo caso quindi sommo tutti i valori in C per cui la corrispondente A sia uguale a Italia.

Ora se al posto del valore fisso Italia volessi inserire un testo in una cella, ad esempio A10, questa formula sembra non funzionare piu.

Dove sbaglio?

Codice: Seleziona tutto
=SOMMA.PIÙ.SE(INDIRETTO(""&$A2&"!C:C"),INDIRETTO(""&$A2&"!A:A"),A10)


Grazie
Spartacus85
Utente Junior
 
Post: 50
Iscritto il: 23/07/13 12:30

Sponsor
 

Re: Combinare SOMMA.PIU.SE e INDIRETTO

Postdi scossa » 04/08/13 15:54

Spartacus85 ha scritto:
Codice: Seleziona tutto
=SOMMA.PIÙ.SE(INDIRETTO(""&$A2&"!C:C"),INDIRETTO(""&$A2&"!A:A"),A10)


Codice: Seleziona tutto
=SOMMA.PIÙ.SE(INDIRETTO(""&$A2&"!C:C"),INDIRETTO(""&$A2&"!A:A"),$A$10)
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: Combinare SOMMA.PIU.SE e INDIRETTO

Postdi Spartacus85 » 04/08/13 21:31

Scossa purtoppo non funziona...
Spartacus85
Utente Junior
 
Post: 50
Iscritto il: 23/07/13 12:30

Re: Combinare SOMMA.PIU.SE e INDIRETTO

Postdi scossa » 05/08/13 08:07

Spartacus85 ha scritto:Scossa purtoppo non funziona...


Io ho preso per buona la tua prima affermazione, ma quelle virgole non mi convinvcono, dovrebbero essere ";".
Prova così:
Codice: Seleziona tutto
=SOMMA.PIÙ.SE(INDIRETTO($A$2&"!C:C");INDIRETTO($A$2&"!A:A");$A$10)
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: Combinare SOMMA.PIU.SE e INDIRETTO

Postdi Spartacus85 » 05/08/13 09:13

Le virgolette nel primo caso, "Italia", vanno bene perche sto cercando un testo.

Nel secondo caso anche sto cercando un testo ma in questo caso legato ad una cella.

Avendo le impostazioni internazionali di windows settate su Inghilterra, il ; é sostituito dalla ,.

Grazie per il supporto però non funziona :(
Spartacus85
Utente Junior
 
Post: 50
Iscritto il: 23/07/13 12:30

Re: Combinare SOMMA.PIU.SE e INDIRETTO

Postdi scossa » 05/08/13 09:39

Spartacus85 ha scritto:Le virgolette nel primo caso, "Italia", vanno bene perche sto cercando un testo.

Nel secondo caso anche sto cercando un testo ma in questo caso legato ad una cella.

Avendo le impostazioni internazionali di windows settate su Inghilterra, il ; é sostituito dalla ,.

Grazie per il supporto però non funziona :(


A me funziona, per cui direi che la cosa migliore da fare è che tu condivida il tuo file per capire dove sta l'inghippo.
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: Combinare SOMMA.PIU.SE e INDIRETTO

Postdi ninai » 05/08/13 10:50

Ciao
Anche a me funziona, ma vedo un pò anomalo mettere in A2 il nome del foglio, In A10 il criterio ed in A:A (senza definire le righe) l'intervallo dei criteri, non conosco lo schema dei dati, ma potrebbe interferire nel conteggio.
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Combinare SOMMA.PIU.SE e INDIRETTO

Postdi scossa » 05/08/13 11:47

ninai ha scritto:Ciao
Anche a me funziona, ma vedo un pò anomalo mettere in A2 il nome del foglio, In A10 il criterio ed in A:A (senza definire le righe) l'intervallo dei criteri, non conosco lo schema dei dati, ma potrebbe interferire nel conteggio.


Ciao ninai ;-)

ma l'intervallo A:A è riferito al Foglio2 mentre A2 e A10 sono, presumo sul Foglio1.
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: Combinare SOMMA.PIU.SE e INDIRETTO

Postdi ninai » 05/08/13 12:00

Come non detto, meglio che mi vado a mangiare una granita :)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Combinare SOMMA.PIU.SE e INDIRETTO

Postdi Spartacus85 » 05/08/13 16:35

Ragazzi funziona, non so per qualche motivo ma prima mi restituiva sempre 0.

Grazie a tutti:)
Spartacus85
Utente Junior
 
Post: 50
Iscritto il: 23/07/13 12:30


Torna a Applicazioni Office Windows


Topic correlati a "Combinare SOMMA.PIU.SE e INDIRETTO":


Chi c’è in linea

Visitano il forum: patel e 16 ospiti