Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

restituzione risultati ricerca verticale

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

restituzione risultati ricerca verticale

Postdi emanuelei » 26/06/13 10:08

Ciao a tutti,

ho un problema con una semplice funzione di ricerca verticale:

la tabella in cui si trovano le informazioni contiene in una colonna "DATE" alcuni valori che si ripetono (ovvero posso avere più righe la cui data è ad esempio 26 giugno) mentre nelle colonne successive i valori sono diversi seppur con la stessa data.

Il mio problema sta nel fatto che se in un altro foglio faccio una ricerca verticale basata sul valore DATA e la riporto su più righe,
continuo ad avere come risultato la prima riga della tabella che contiene la data che sto cercando e non risco a scalare alle righe successive.

Qualcuno potrebbe gentilmente dirmi come faccio a far scalare ai risultati delle righe successive?

GRAZIE!!

Emanuele
emanuelei
Utente Junior
 
Post: 21
Iscritto il: 27/10/12 15:51

Sponsor
 

Re: restituzione risultati ricerca verticale

Postdi CANAPONE » 26/06/13 10:17

Ciao,

in Z2 la data della quale cerchi la corrispondenza


=SE.ERRORE(INDICE($B$2:$B$100;PICCOLO(SE($A$2:$A$100=$Z$2;RIF.RIGA($A$2:$A$100)-1);RIGHE($A$1:A1)));"")

Formula matriciale.

La formula va copiata e confermata con control+maiusc+invio prima di essere copiata in basso per ottenere la seconda/terza... corrispondenza.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: restituzione risultati ricerca verticale

Postdi emanuelei » 26/06/13 19:53

Grazie per la tua risposta rapidissima!

So come funzionano le formule matriciali con { } ma non ho capito com'è impostata la formula che mi hai suggerito!

Credo di essermi spiegato male. Provo ad allegare qui un immagine del mio file.

TABELLA DATI (1000 righe)

possibili valori colonna A: "ck-in"; "ck-out"; "cleaning"; riga vuota
valori colonna B: date
valori colonna C: prezzi

RISULTATO DESIDERATO SU ALTRO FOGLIO

lista delle sole linee che hanno "ck-in" in colonna A, evitando righe vuote

PROBLEMA

se faccio una ricerca verticale cercando "ck-in" mi viene continuamente riportata la prima riga della tabella dati che ha "ck-in" nella colonna A e non so come passare alle righe successive.

Grazie ancora per l'aiuto prezioso! Spero di essermi spiegato meglio!

Emanuele
emanuelei
Utente Junior
 
Post: 21
Iscritto il: 27/10/12 15:51

Re: restituzione risultati ricerca verticale

Postdi CANAPONE » 26/06/13 20:21

Ciao,

nell'esempio i dato sonop nel foglio1


Date In A2 (esempio) del secondo foglio. Prima data

Codice: Seleziona tutto
=SE.ERRORE(INDICE(Foglio1!$B$2:$B$1000;PICCOLO(SE(Foglio1!$A$2:$A$1000= "ck-in";RIF.RIGA($A$2:$A$1000)-1);RIGHE($A$1:A1)));"")


Prezzi in B2 del secondo foglio. Prezzo riferito prima data

Codice: Seleziona tutto
=SE.ERRORE(INDICE(Foglio1!$C$2:$C$1000;PICCOLO(SE(Foglio1!$A$2:$A$1000= "ck-in";RIF.RIGA($A$2:$A$1000)-1);RIGHE($A$1:A1)));"")

Una volta confermate con control+miausc+invio copiale in basso.

Sto usando formule valide per Excel 2007 o versioni successive
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: restituzione risultati ricerca verticale

Postdi emanuelei » 27/06/13 11:38

Grazie nuovamente!
Mi sono studiato formule che non conoscevo tipo se.errore, indice, confronta... etc. ma ho paura di essermi spiegato male nel mio primo messaggio.
La data infatti è una informazione come il prezzo ed altre che si trovano sulle colonne successive e non guida la ricerca.

Ricapitolo il problema

Foglio 1 - fonte dati

colonna A (a2:a1000)
=> c'è l'indicazione del tipo di operazione (ck-in; ck-out; cleaning) e ci sono linee vuote.

colonna B e C b2:c1000)
=> ci sono altre informazioni

Foglio 2 - risultato atteso

colonna A, B e C
=> solo le linee che hanno operazione tipo "ck-in" senza spazi vuoti

Spero di essere stato più chiaro e mi scuso se non lo sono stato fin da subito!

Grazie ancora!
emanuelei
Utente Junior
 
Post: 21
Iscritto il: 27/10/12 15:51

Re: restituzione risultati ricerca verticale

Postdi wallace&gromit » 27/06/13 13:36

ma non è sufficiente filtrare i dati con un filtro automatico?
In prima battuta filtri tutti i dati che in colonna A contengono "ck-in", poi procedi con i filtri che ti interessano sulle altre colonne, infine fai copia e incolla e sul foglio 2 avrai solo le righe filtrate.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: restituzione risultati ricerca verticale

Postdi CANAPONE » 27/06/13 14:20

Ciao a tutti

uso più o meno le stesse formule, ma sono su Excel 2003

https://dl.dropboxusercontent.com/u/106 ... heckin.xls


Puoi usare se.errore per correggere i risultati non voluti nelle formule dell'allegato

Codice: Seleziona tutto
=SE.ERRORE(INDICE(Foglio1!$A$2:$A$1000;PICCOLO(SE(VAL.NUMERO(TROVA("ck-in";Foglio1!$A$2:$A$1000&Foglio1!$B$2:$B$1000&Foglio1!$C$2:$C$1000));RIF.RIGA($A$2:$A$1000)-1);RIGHE($A$1:A1)));"")



Prova ad allegare un esempio con i risultati attesi, se avessi bisogno di qualcosa di diverso.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: restituzione risultati ricerca verticale

Postdi emanuelei » 04/07/13 23:07

Ottimo, grazie!!!
emanuelei
Utente Junior
 
Post: 21
Iscritto il: 27/10/12 15:51


Torna a Applicazioni Office Windows


Topic correlati a "restituzione risultati ricerca verticale":


Chi c’è in linea

Visitano il forum: Marius44 e 7 ospiti