Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel: ricerca di n numeri grandi su varie righe

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: excel: ricerca di n numeri grandi su varie righe

Postdi elromanito » 17/06/13 17:16

ricky53 ha scritto:Ciao,
in un cella libera sulla stessa riga di Antonio scrivi
Codice: Seleziona tutto
=SE(VAL.ERRORE(CONFRONTA(GRANDE($B$2:$K$4;A$1); $B2:$K2; 0)); "-"; CONFRONTA(GRANDE($B$2:$K$4;A$1); $B2:$K2; 0))


copia in basso ed avrai il numero della colonna dell'intervallo di dati che contiene il "decimo" valore più grande di quelli dell'intervallo dei dati.
La colonna n. 1 è la "B", la n. 2 è la "C", ...

Nel tuo esempio dovresti ottenere "6" sulla riga di Antonio ossia la colonna "G"

esatto. è proprio così

grazie ancora ricky53; ancora una volta mi sento proprio che devo studiare, ma tanto proprio :eeh:
elromanito
Utente Junior
 
Post: 17
Iscritto il: 14/06/13 12:27

Sponsor
 

Re: excel: ricerca di n numeri grandi su varie righe

Postdi ninai » 17/06/13 19:28

Ciao
se ho capito bene, un alternativa:
=MATR.SOMMA.PRODOTTO((B2:K4=GRANDE($B$2:$K$4;$A$1))*RIF.COLONNA(B1:K1))-1
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "excel: ricerca di n numeri grandi su varie righe":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti