Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Contatore per ambi (gioco del lotto) senza macro.

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Contatore per ambi (gioco del lotto) senza macro.

Postdi nelson1331 » 02/06/13 10:48

Vorrei sapere se attraverso formule abbinate, del tipo conta.se e cerca.vert, e' possibile contare gli ambi (1 per ogni riga) disposti ad esempio, dalla A1 alla B4005. Come avviene per il conta.se, che e' in grado di indicarmi gli estratti in base alla funzione (>di...)
cosi' vorrei analoga formula, per trovare le quantita' degli ambi in base all' opzione (>di...) lungo le colonne suddette. In pratica, nel range prestabilito da A1-B4005, vorrei sapere, ogni ambo ivi presente, quante volte e' ripetuto.
E' mio desiderio, trovare una soluzione adatta, attraverso formule e non con le macro.
Grazie a chi mi rispondera'.
Nelson
nelson1331
Utente Junior
 
Post: 39
Iscritto il: 18/02/08 08:58

Sponsor
 

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi CANAPONE » 02/06/13 11:59

Ciao,

se scrivi i due numeri che cerchi in C1 e D1

Codice: Seleziona tutto
=SOMMA(--(MATR.PRODOTTO(CONTA.SE(C1:D1;$A$1:$B4005);{1.1})=2))


dovrebbe fare quello che chiedi.

Spero sia d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi Anthony47 » 02/06/13 12:04

Immagino che A1:B4005 contenga le possibili 4005 combinazioni di ambo, quindi temo che la formula suggerita da canapone (vedi sopra) non sia applicabile.

Non essendomi chiaro come sono i tuoi, puoi pubblicarne uno screenshot? oppure, se i dati sono lunghi da replicare, direttamente un file di esempio? Per come fare vedi qui: viewtopic.php?f=26&t=80395

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi CANAPONE » 02/06/13 12:12

Ciao Anthony47,

mi ero anche chiesto il motivo delle 2 colonne e delle 4005 righe: meglio vada a mangiare.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi Anthony47 » 02/06/13 12:21

Ci vado anche io!
Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi nelson1331 » 02/06/13 13:42

http://imageshack.us/content_round.php? ... 5ambis.jpg
Vi allego una schermata indicandovi questi elementi essenziali.
Vi sono 15 colonne da 4005 ambi cadauna : le prime cinque sono nelle colonne A-B G-H M-N S-T Y-Z (Per semplicita' vi ho indicato solo le prime 5 colonne) : come noterete dall' immagine, ne seguono, altre 10.
La linea o riga di partenza di ogni ambo, e' sempre la n°13 e la linea finale e' sempre la n°4017.
Tutte le celle, contengono solo numeri : non ci sono celle vuote e neppure caratteri alfabetici.
Non sono ordinati, in ordine di linea (cioe' dal numero piu' piccolo, al numero piu' grande).
Non sono ordinati, in ordine di colonna (cioe' dall' ambo piu' piccolo, all' ambo piu' grande).
Tutti i numeri racchiusi in questi range, vanno ovviamente da 1 a 90.
La 1° colonna, puo' contenere lo stesso numero sulla 2° colonna, ovvero medesimo numero sulla stessa linea : questo per me non rappresenta un problema dal punto di vista del contatore. In pratica non e' piu' ambo ma, doppia ambata e anche se il contatore non riesce a gestire questi casi, nessun problema.
nelson1331
Utente Junior
 
Post: 39
Iscritto il: 18/02/08 08:58

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi CANAPONE » 02/06/13 14:46

Ciao,

per capire, in G1:O10 ci sono le estrazioni e devi calcolare riga per riga se sono presenti l' 85 e l'82 (A13 e B13), poi 85-79 (A14 e B14)...e contare gli ambi su ogni coppia di colonne.

E' questo il calcolo?

Per provare ad abbozzare una soluzione.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi nelson1331 » 02/06/13 14:59

No, Canapone, il contatore degli ambi, vagliando tutti i 4005 ambi possibili, mi dovra' dire, per gli ambi ad esempio da A13-B4017 quante volte si e' ripetuto l' ambo 85.82 (1° linea) e poi, quante volte si e' ripetuto l' ambo 85.79 (2° linea) e poi quante volte si e' ripetuto l' ambo 85.86 (3° linea) e cosi' via fino all' ultima linea in questione. In pratica, mi dovra' creare una nuova colonna, contenente tutti e 4005 gli ambi del lotto, in cui mettera' in risalto (in questo caso solo gli ambi racchiusi nel range A13-B4017), con le rispettive presenze.
Un contatore di presenze, che anziche' lavorare sui 90 estratti, dovra' lavorare sulle 4005 combinazioni degli ambi e poi si dovra' confrontare sul range prescelto.
L' area dati : G1-O10, non c' entra nulla : dimenticala.
nelson1331
Utente Junior
 
Post: 39
Iscritto il: 18/02/08 08:58

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi CANAPONE » 02/06/13 15:15

Ciao,

esempio in F13

Codice: Seleziona tutto
=SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13:B13;$A$13:$B4005);{1.1})=2))


conta quante volte l'ambo 85 82 ( o 82 85 se esiste) è presente nelle righe 13:4005

Copiando in basso la formula vedi tutte le combinazioni.

Non so se è d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi nelson1331 » 02/06/13 16:01

Ciao Canapone : ho utilizzato la tua formula e poi ho fatto le verifiche.
=SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13:B13;$A$13:$B$4017);{1.1})=2))
Ho ordinato tutte e 2 le colonne, prima per riga (dal valore piu' piccolo al piu' grande) e poi per colonna (con la funzione di excel ordina per colonne, sempre dall' ambo piu' piccolo al piu' grande). Se in realta' prendo uno degli ambi contenuti e controllo il numero delle sue presenze (ho preso ad esempio l' ambo 77.80), il tuo contatore mi dice 6 presenze, mentre avendo fatto i passaggi di cui sopra, a me risultano 4 presenze. Sbaglio in qualche passaggio, oppure la tua formula richiede un adattamento ulteriore ?
nelson1331
Utente Junior
 
Post: 39
Iscritto il: 18/02/08 08:58

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi CANAPONE » 02/06/13 20:26

Ciao,

la formula che cerca gli ambi 85-89 (89-85) trova probabilmente nelle doppie colonne ambi tipo 85 85 ed 89 89

Così dovresti escluderli.


Codice: Seleziona tutto
=SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13:B13;$A$13:$B$4017);{1.1})=2))-SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13;$A$13:$B$4017);{1.1})=2))-SOMMA(--(MATR.PRODOTTO(CONTA.SE(B13;$A$13:$B$4017);{1.1})=2))


Meglio ancora:

Codice: Seleziona tutto
=SE(A13=B13;"";SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13:B13;$A$13:$B$4017);{1.1})=2))-SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13;$A$13:$B$4017);{1.1})=2))-SOMMA(--(MATR.PRODOTTO(CONTA.SE(B13;$A$13:$B$4017);{1.1})=2)))




Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi nelson1331 » 02/06/13 21:15

Grazie Canapone. Ho fatto alcune verifiche ed i valori della formula, corrispondono a quelli che ricavo. Bravo e complimenti. Nelson
nelson1331
Utente Junior
 
Post: 39
Iscritto il: 18/02/08 08:58

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi nelson1331 » 07/06/13 07:06

Altra piccola domanda. Avrei bisogno di creare una colonna di ambi ma, che questa volta me li legga dalla fine all' inizio. Manteniamo valido il range da A13-B4017.
Ipotizziamo che nella 1° riga di questo range, vi sia l' ambo 11.45
Ipotizziamo che nella 2° riga di questo range, vi sia l' ambo 13.47
Ipotizziamo che nella 3° riga di questo range, vi sia l' ambo 31.69
....
Ipotizziamo che nella riga n°4003, vi sia l' ambo 79.87
Ipotizziamo che nella riga n° 4004,vi sia l' ambo 15.33
Ipotizziamo che nella riga n° 4005,vi sia l' ambo 18.41
Adesso vorrei (attraverso la formula che mi indicherete), creare una nuova colonna, nella quale, al fianco del 1° ambo sulla 1° riga (cioe' 11.45), venga ad affiancarsi nelle celle d13-e13, l' ultimo ambo, ovvero il 18.41
Vorrei ancora, che l' ambo della 2° riga (13.47) abbia al suo fianco, l' ambo della penultima riga e cioe' nelle celle d14-e14, l' ambo 15.33
E cosi' via.
In pratica la 2° colonna che vorrei costruire, dovra' replicare esattamente la 1° colonna di lettura con i 4005 ambi ma, questa volta in modo inverso : lettura dal basso verso l' alto.
Mi servira' per capire la funzione degli indici, e la disposizione degli ambi vincenti. Grazie ancora una volta a chi mi aiutera'. Nelson
nelson1331
Utente Junior
 
Post: 39
Iscritto il: 18/02/08 08:58

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi CANAPONE » 07/06/13 07:39

In A13:A4017 solo numeri


In C13

Codice: Seleziona tutto
=INDICE($A$13:$A$4017;CONTA.VALORI(A13:$A$4017))


In D13

Codice: Seleziona tutto
=INDICE($B$13:$B$4017;CONTA.VALORI(B13:$B$4017))


Lascia libero il riferimento di A13 e B13 nei CONTA.VALORI

Meglio se non accodi le domande a thread già chiusi: ottieni maggiore visibilità e dai maggiore visibilità a risposte che potrebbero essere utili a qualcun altro.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi nelson1331 » 07/06/13 15:16

Ciao Canapone. Anche questa volta ho fatto le prove e tutto funziona bene. Grazie, Nelson
nelson1331
Utente Junior
 
Post: 39
Iscritto il: 18/02/08 08:58

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi Cele79 » 11/03/14 11:21

Ciao a tutti!
Ho provato questa formula
Codice: Seleziona tutto
=SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13:B13;$A$13:$B4005);{1.1})=2))

ma mi dice che c'è un errore nella formula!
Come mai?
grazie
Cele79
Utente Junior
 
Post: 82
Iscritto il: 14/01/14 12:32

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi Anthony47 » 11/03/14 12:53

Quale versione di Excel usi?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi Cele79 » 11/03/14 12:54

Excel 2007
Cele79
Utente Junior
 
Post: 82
Iscritto il: 14/01/14 12:32

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi Anthony47 » 11/03/14 12:56

Quale e' il tuo separatore decimale, nei numeri?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Contatore per ambi (gioco del lotto) senza macro.

Postdi Anthony47 » 11/03/14 12:57

Comunque prova una di queste varianti:
=SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13:B13;$A$13:$B4005);{1,1})=2))

=SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13:B13;$A$13:$B4005);{1;1})=2))

=SOMMA(--(MATR.PRODOTTO(CONTA.SE(A13:B13;$A$13:$B4005);{1\1})=2))
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Prossimo

Torna a Applicazioni Office Windows


Topic correlati a "Contatore per ambi (gioco del lotto) senza macro.":


Chi c’è in linea

Visitano il forum: Nessuno e 21 ospiti