Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - Ripetizione celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel - Ripetizione celle

Postdi gaetano73 » 06/03/13 16:58

Ciao a tutti. Uso Excel 2003.
Devo fare una cosa del genere:
Da A1 a J1 (10 celle) sono popolate con dei valori alfabetici. In K1 inserisco un numero (< 10). Vorrei che le celle dalla AB1 alla ABn si popolassero con gli ultimi 10-K1 valori.

Esempio con 4 celle:
- A1: Paolo
- A2: Giorgio
- A3: Gianluca
- A4: Cristina
In A5 inserisco 2.
In automatico nella A6 e nella A7 si trascrivono Gianluca e Cristina (o anche Cristina e Gianluca; l'ordine non importa).

Grazie

Gaetano
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36

Sponsor
 

Re: Excel - Ripetizione celle

Postdi gaetano73 » 06/03/13 22:06

Ho risolto con un CONTA.VALORI() annidato in un SE()... grazie lo stesso a tutti.

Ciao
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36

Re: Excel - Ripetizione celle

Postdi Anthony47 » 06/03/13 22:33

In alternativa alla tua soluzione...
I tuoi dati sono in A1:J1; il numero di elementi e' in K1;in AB1 inserisci la formula
Codice: Seleziona tutto
=SE(RIF.RIGA(A1:A10)<=$K$1;INDICE(A1:J1;GRANDE(RIF.COLONNA(A1:J1);RIF.RIGA(A1:A10)));"")

Selezioni a questo punto l' area AB1:AB10, premi F2, premi Contr-Maiusc-Enter per immettere la formula in tutto l' intervallo.
Questo dovrebbe restituire il risultato che cerchi.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel - Ripetizione celle

Postdi gaetano73 » 07/03/13 13:35

Ottima alternativa! Grazie!
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36


Torna a Applicazioni Office Windows


Topic correlati a "Excel - Ripetizione celle":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti

cron