Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

una serie di valori incrementali

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

una serie di valori incrementali

Postdi luca62 » 04/03/13 13:55

Allego un file: http://www.filedropper.com/com5001

nel primo foglio stampi dia 60 voglio creare una colonna (H) come ho creato in maniera manuale,
automatizzando il procedimento.
inpratica con la funziona SE posta in h3:
=SE(C3=COSTI!D$2;COSTI!G$2;0) la funzione controlla che il il valore posto in C3 del foglio
di lavoro stampi 60 , se è uguale al valore della cella D$2 della cartella COSTI, allora il
valore della cella h3= al valore della cella G$2 in costi.

nelle righe successive (H4) dovrei scrivere:
=SE(C4=COSTI!K$2;COSTI!N$2;0)
ossia incremento da C3 a C4 (OSSIA +1 SULLA RIGA))
..............COSTI!D$2 A COSTI!K$2 (OSSIA +7 SULLA COLONNA
..............COST!G$2 A COST!N$2 (OSSIA + 7 SULLA COLONNA)


E COSì VIA, OSSIA TEORICAMENTE, MA NON LO SO ESPLICITARE:
NELLA CASELLA Hi dovrei scrivere
=SE(Ci=COSTI!(D+n*p)$2;COSTI!(G+n*p)$2;0)


ossia p =passo =7
n= Hì-H3

spero di essermi spiegato
luca62 office2007 window7
luca62
Utente Senior
 
Post: 158
Iscritto il: 23/12/12 14:54

Sponsor
 

Re: una serie di valori incrementali

Postdi wallace&gromit » 04/03/13 14:34

una formula (un po' complessa) da mettere in h3 e trascinare verso il basso, potrebbe essere:
Codice: Seleziona tutto
=SE(C3=INDIRETTO(INDIRIZZO(2;4+7*(RIF.RIGA()-3);;;"COSTI"));INDIRETTO(INDIRIZZO(2;7+7*(RIF.RIGA()-3);;;"COSTI")))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: una serie di valori incrementali

Postdi luca62 » 04/03/13 14:59

funzionicchia... nel senso che se la condizione ad esempio in H10 mi da falso, tutti i valori seguenti mi da falso,
luca62 office2007 window7
luca62
Utente Senior
 
Post: 158
Iscritto il: 23/12/12 14:54

Re: una serie di valori incrementali

Postdi wallace&gromit » 04/03/13 17:05

probabilmente questo succede perchè nel foglio COSTI manca una colonna (o ce n'è una di troppo) prima della colonna BA e la colonna cui fa riferimento la formula H10 è sfasata, da quel punto è ovvio che sono tutte sfasate, perchè il passo è sempre mantenuto costante.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: una serie di valori incrementali

Postdi luca62 » 05/03/13 07:38

no il problema è un altro, il foglio costi è ok ma il problema nasce dal fatto che dalla lista del foglio principale,
posso avere una riga che "non ha costo" e quindi non è presente nelò riepilogo costi.
(nel file allegato casualmente tutte le righe sono presenti nel riepilogo costi) , ho provveduto allora
a spostare in basso della lista del foglio principali quelle voci che non hanno un costo , e così va tutto bene
ssenza ulteriore complicazioni
grazie
luca62 office2007 window7
luca62
Utente Senior
 
Post: 158
Iscritto il: 23/12/12 14:54


Torna a Applicazioni Office Windows


Topic correlati a "una serie di valori incrementali":


Chi c’è in linea

Visitano il forum: Nessuno e 24 ospiti