Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Media 1,2,3 Valori Più grandi

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Media 1,2,3 Valori Più grandi

Postdi Francesco6918 » 24/02/13 21:55

Buona Sera a tutti un aiuto vorrei fare la media dei (3,2,1,0) valori più grandi in un intervallo di 6 celle,vorrei precisare che i valori presenti nel intervallo sono valori copiati come da file che invio.

Saluti

Francesco

www.filedropper.com/esempiomedia3valoripigrandi
Francesco6918
Utente Senior
 
Post: 147
Iscritto il: 04/03/11 11:20

Sponsor
 

Re: Media 1,2,3 Valori Più grandi

Postdi Anthony47 » 24/02/13 23:10

Nell' ipotesi che tu voglia fare la media dei 3 numeri piu' grandi presenti in J4:O4 allora potrai usare la formula
Codice: Seleziona tutto
=SOMMA(GRANDE($J$4:$O$4;RIF.RIGA(INDIRETTO("A1:A3"))))/3
Da confermare con Contr-Maiusc-Enter.
Se invece vuoi poter calcolare la mesia del singolo, dei 2 maggiori, dei 3 maggiori etc allora puoi partire con l formula
Codice: Seleziona tutto
=SOMMA(GRANDE($J$4:$O$4;RIF.RIGA(INDIRETTO("A1:A"&RIF.RIGA(A1)))))/RIF.RIGA(A1)
Sempre Contr-Maiusc-Enter.
Questa calcola "la media" del singolo numero piu' grande; copiandola verso il basso il calcolo sara' fatto sui 2, sui 3 etc numeri piu' alti dell' intervallo.

Se invece volevi una cosa diversa allora devi spiegare nuovamente.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Media 1,2,3 Valori Più grandi

Postdi Francesco6918 » 25/02/13 01:27

Ciao Anthony la prima formula va bene mi calcola la media dei 3 valori più grandi ma come e possible inserendo solo 2 valori 78 e 70 la media e 49 la regola dovrebbe essere (74) se inserisco solo il 78 la media e 26 (78) .
Francesco6918
Utente Senior
 
Post: 147
Iscritto il: 04/03/11 11:20

Re: Media 1,2,3 Valori Più grandi

Postdi ricky53 » 25/02/13 10:55

Ciao,
la formula che ti ha proposto Anthony era stata progettata secondo quanto tu avevi scritto.
In sintesi tre valori quindi la divisione è fatta per "3".

Se cambi la condizioni devi cambiare la formula.

Sarebbe necessario generalizzarla.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Media 1,2,3 Valori Più grandi

Postdi Flash30005 » 25/02/13 14:09

Per "generalizzarla" si potrebbe modificare così
Codice: Seleziona tutto
=SOMMA(GRANDE($J$4:$O$4;RIF.RIGA(INDIRETTO("A1:A3"))))/SE(CONTA.VALORI(J4:O4)<3;CONTA.VALORI(J4:O4);3)


ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Media 1,2,3 Valori Più grandi

Postdi Anthony47 » 25/02/13 14:12

Confermo quanto scritto da Ricky, e aggiungo che basterebbe che l' elenco contenga solo 2 numeri e la media torna corretta; invece le tue formule mettono "0" dappertutto, che salvo smentita e' un numero valido...
Modifica le tue formule:
non =LaCella
ma =SE(LaCella="";"";LaCella)

Ciao

Ps: questo supera anche la formula di Flash, che probabilmente non funzionerebbe visto la presenza degli "0" nelle celle.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Media 1,2,3 Valori Più grandi

Postdi Francesco6918 » 25/02/13 14:14

Grazie Flash provo ti faccio sapere

Saluti

Francesco
Francesco6918
Utente Senior
 
Post: 147
Iscritto il: 04/03/11 11:20

Re: Media 1,2,3 Valori Più grandi

Postdi Francesco6918 » 25/02/13 14:16

Ciao Anthony completami la formula cosi la inserisco.
Francesco6918
Utente Senior
 
Post: 147
Iscritto il: 04/03/11 11:20

Re: Media 1,2,3 Valori Più grandi

Postdi Francesco6918 » 25/02/13 14:29

Flash dovrei fare le prove su quello che sto creando dunque ti informo in serata dovrei andare a lavoro.

Saluti
Francesco6918
Utente Senior
 
Post: 147
Iscritto il: 04/03/11 11:20

Re: Media 1,2,3 Valori Più grandi

Postdi Anthony47 » 25/02/13 14:42

Ciao Anthony completami la formula cosi la inserisco.
Nel tuo file, in J4 hai inserito la formula =T4; modificala in =SE(T4="";"";T4)
Idem le formule adiacenti (ma ti bastera' copiare J4 verso destra).

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Media 1,2,3 Valori Più grandi

Postdi Francesco6918 » 25/02/13 19:56

Ciao Anthony comunque sia va bene l importante che mi calcoli la media dei 3 valori più grandi

Saluti
Francesco6918
Utente Senior
 
Post: 147
Iscritto il: 04/03/11 11:20

Re: Media 1,2,3 Valori Più grandi

Postdi Anthony47 » 25/02/13 22:51

Hai avuto la posssibilita' di provare le formule che ti avevo dato?

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Media 1,2,3 Valori Più grandi

Postdi Francesco6918 » 25/02/13 23:46

Ciao Anthony o valutato la formula può andare bene solo una cosa se l intervallo e privo di valori mi restituisce come errore #NUM!
se possibilmente e correggibile. (EXCEL 2010)

Grazie
Francesco6918
Utente Senior
 
Post: 147
Iscritto il: 04/03/11 11:20

Re: Media 1,2,3 Valori Più grandi

Postdi Flash30005 » 26/02/13 01:17

Non avevo scaricato il file e non sapevo della presenza degli 0 (zero) ma modificando opportunatamente la formula
a me sembra funzionare tranne nuove specifiche...
Codice: Seleziona tutto
=SOMMA(GRANDE($J$4:$O$4;RIF.RIGA(INDIRETTO("A1:A3"))))/SE(CONTA.SE(J$4:O$4;"<>0")<3;CONTA.SE(J$4:O$4;"<>0");3)


ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Media 1,2,3 Valori Più grandi

Postdi Francesco6918 » 26/02/13 23:43

Ciao Anthony e Flash le provo tutte su quello che sto creando penso una o l altra andrà bene vi ringrazio se o problemi vi informo

Saluti
Francesco6918
Utente Senior
 
Post: 147
Iscritto il: 04/03/11 11:20

Re: Media 1,2,3 Valori Più grandi

Postdi Anthony47 » 27/02/13 01:25

Usa la formula di Flash, usando in J4:O4 le formule che riportavano "0" in caso di cella vuota.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Media 1,2,3 Valori Più grandi":


Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti