Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] confrontare valore celle solo se contengono testo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] confrontare valore celle solo se contengono testo

Postdi Dylan666 » 11/02/13 18:59

Buongiorno a tutti avrei il seguente quesito: utilizzando la formula SE (o altre se ritenute più opportune) come è possibile confrontare il contenuto di due celle (per vedere se è identico) solo se le stesse due contengono solo testo?

Grazie anticipatamente
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Sponsor
 

Re: [EXCEL] confrontare valore celle solo se contengono test

Postdi ricky53 » 11/02/13 20:52

Ciao,
prova con
Codice: Seleziona tutto
=SE(T(Tua Cella)=""; "Numero"; "Testo")

oppure con
Codice: Seleziona tutto
=SE(VAL.ERRORE(VALORE(Tua Cella)); "Testo"; "Numero")


Così riesci ad identificare se una cella contiene un numero od un testo poi devi mettere i "Confronti" (con la funzione "SE") per stabilire l'uguaglianza delle celle.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [EXCEL] confrontare valore celle solo se contengono test

Postdi Anthony47 » 12/02/13 00:04

Vista la disponibilita' di una funzione di "valore.testo" io la userei in una formula tipo
Codice: Seleziona tutto
=E(VAL.TESTO(A1);A1=B1)
A1 e B1 sono le celle da confrontare; il risultato sara' VERO se le due celle sono uguali e contengono testo; FALSO negli altri casi.
A meno che quando dici "solo testo" vorresti escludere stringhe quali "pippo11" (ma anche per questo c' e' la cura)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] confrontare valore celle solo se contengono test

Postdi ricky53 » 12/02/13 01:18

Ciao Anthony,
che dire: soluzione potente ed ottimizzata.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [EXCEL] confrontare valore celle solo se contengono test

Postdi Karistotele1 » 12/02/13 04:15

Essendo "PIPPO" diverso da "pippo" integrerei la formula di Anthony:

Codice: Seleziona tutto
=E(VAL.TESTO(A1);IDENTICO(A1;B1))
Ciao da K
Karistotele1
Utente Junior
 
Post: 10
Iscritto il: 21/01/13 07:11
Località: Padova

Re: [EXCEL] confrontare valore celle solo se contengono test

Postdi Dylan666 » 12/02/13 15:58

La formula mi restituisce FALSO anche se le due colonne hanno entrambe numeri.
Evidentemente ho approcciato male io il seguente problema:

Nella colonna A ho una serie di valori che potrebbero essere numeri o testi
Nella colonna B ho la stessa situazione.

Mi seriverebbe di capire quando in una cella di A c'è un numero mentre in quella di B subito a fianco c'è invece un testo o viceversa.
Se in entrambi hanno del testo mi servirebbe di capire quando è diverso tra A e B

Se i due testi sono identici non mi interessa
Se le due celle hanno numeri non mi interessa

La distinzione maiuscole e minuscole non ha importanza (niente IDENTICO insomma)

Grazie
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: [EXCEL] confrontare valore celle solo se contengono test

Postdi ricky53 » 12/02/13 17:52

Ciao,
alla luce di quanto hai scritto io ho capito quanto vedi nell'esempio
1 - 1 - FALSO
1 - a - VERO
a - 1 - VERO
a - a - FALSO
a - c - VERO

... l'ho fatta complicata ma dovrebbe andare bene
Codice: Seleziona tutto
=O(E(VAL.TESTO(A5); VAL.TESTO(B5); A5<>B5); E(VAL.TESTO(A5); NON(VAL.TESTO(B5)));  E(NON(VAL.TESTO(A5)); VAL.TESTO(B5)))


A me fornisce i risultati aspettati che ho esposto sopra.
Prova e ... sono QUI
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] confrontare valore celle solo se contengono testo":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti