Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - Copia Valori

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel - Copia Valori

Postdi tosessa » 08/02/13 10:13

Salve mi ritrovo un problema in Excel, devo riportare solo il risultato numerico di una colonna di celle contenente questa formula :
=SE(H2"";"";(O2*H2)) in una colonna adiacente in automatico e possibile!
tosessa
Utente Junior
 
Post: 23
Iscritto il: 08/02/13 09:01

Sponsor
 

Re: Excel - Copia Valori

Postdi wallace&gromit » 08/02/13 11:28

ciao, per iniziare manca un "=":
Codice: Seleziona tutto
=SE(H2="";"";(O2*H2))
se non risolve spiega ancora il problema
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: Excel - Copia Valori

Postdi Flash30005 » 08/02/13 11:34

Ciao Tosessa e benvenuto/a nel Forum
Non dici in quale colonna devono essere riportati i dati numerici
per automatizzare si deve creare una macro e senza riferimenti (colonna con formule e colonna output, solo dati), non è possibile crearla
Puoi comunque registrare una macro, dopo avvio registrazione
selezioni la colonna con formule,
esegui l'azione di "Copia"
selezioni la colonna destinazione
esegui l'operazione di "Incolla Speciale", solo valori
Fermi la registrazione
Vai nel Vba editor premendo i tasti Alt+F11
e troverai la macro che hai registrato e ogni volta verrà avviata automatizzerà le operazioni da te effettuate.
Se vuoi puoi pubblicare l'intero codice così l'ottimizziamo

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel - Copia Valori

Postdi tosessa » 08/02/13 13:11

Grazie ragazzi, comunque per la registrazione della macro già l'avevo pensato ed ho provato ma per una strana coincidenza dopo il fermo della registrazione non registra codice nella macro. comunque la colonna U segna i dati ottenuti dalla formula mentre la colonna A deve ricevere solo i dati numerici.
e possibile creare il codice?
tosessa
Utente Junior
 
Post: 23
Iscritto il: 08/02/13 09:01

Re: Excel - Copia Valori

Postdi Flash30005 » 08/02/13 14:59

:roll: Strano che non registra alcun codice
Comunque prova questa macro
Codice: Seleziona tutto
Sub CopiaValori()
    Columns("U:U").Copy
    Columns("A:A").PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
        :=False, Transpose:=False
        Application.CutCopyMode = False
        [A1].Select
End Sub


Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel - Copia Valori

Postdi tosessa » 14/02/13 12:18

Ciao Grazie a tutti per i consigli ho risolto il problema.
adesso mi chiedevo se potreste aiutarmi, vorrei se è possibile contare le celle in base ai colori grazie. :aaah
tosessa
Utente Junior
 
Post: 23
Iscritto il: 08/02/13 09:01

Re: Excel - Copia Valori

Postdi Flash30005 » 14/02/13 12:41

In quale range?
I colori sono "fisici" oppure dovuti ad una formattazione condizionale?
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel - Copia Valori

Postdi tosessa » 14/02/13 14:19

Sono fisici inseriti nelle celle da me!
tosessa
Utente Junior
 
Post: 23
Iscritto il: 08/02/13 09:01

Re: Excel - Copia Valori

Postdi Anthony47 » 14/02/13 14:38

Guarda questa discussione: viewtopic.php?f=26&t=72430#p412767
Prova a usare la Function CCC, usandola poi in una formula tipo
Codice: Seleziona tutto
=CCC(SCells;TCell)
SCell sono le celle in cui contare; TCell e' la cella col colore campione

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel - Copia Valori":


Chi c’è in linea

Visitano il forum: raimea e 11 ospiti