Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Media con condizioni su excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Media con condizioni su excel

Postdi Beppe16v » 21/01/13 11:44

Buongiorno a tutti. Vi chiedo un piccolissimo (per voi) aiuto su come risolvere un blocco che ho su un doc excel che sto creando.

Fate conto di avere 6 colonne A1:F1 dove ci possono essere dei valori come non. In G1 ho la somma, mentre in H1 Devo semplicemente fare una media degli stessi valori (quindi non tutte le righe avranno i dati su tutti e 6, ma possono averne anche meno) a queste condizioni aggiuntive: se presenti da 2 a 3 valori fare la media scartando quello più alto. Se presenti 4, 5 o 6 valori fare la media scartando i due valori più alti.

Ci fosse solo la prima condizione, con la funzione "media", la "conta.valori" e la "max" mi ci arrangio grosso modo. Ma con la doppia condizione che ho bisogno mi incarto... Grazie neh! ;)
Beppe16v
Utente Junior
 
Post: 32
Iscritto il: 12/09/06 13:47

Sponsor
 

Re: Media con condizioni su excel

Postdi Flash30005 » 21/01/13 11:56

In H1 inserisci questa formula
Codice: Seleziona tutto
=SE(CONTA.VALORI(A1:F1)>3;(SOMMA(A1:F1)-GRANDE(A1:F1;1)-GRANDE(A1:F1;2))/(CONTA.VALORI(A1:F1)-2);(SOMMA(A1:F1)-GRANDE(A1:F1;1))/(CONTA.VALORI(A1:F1)-1))

poi trascinala in basso fino dove occorre

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Media con condizioni su excel

Postdi Beppe16v » 21/01/13 19:09

Ecco, non conoscevo la funzione "grande"... beh, GRANDE! Grazie mille! :D
Beppe16v
Utente Junior
 
Post: 32
Iscritto il: 12/09/06 13:47


Torna a Applicazioni Office Windows


Topic correlati a "Media con condizioni su excel":


Chi c’è in linea

Visitano il forum: albval e 32 ospiti