Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] condizione se e moltiplicazione

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] condizione se e moltiplicazione

Postdi riskismoney » 03/01/13 14:24

Ho un piccolo problema che non riesco a risolvere:
nella colonna A ho una stringa ("si" oppure "no"),
nelle colonne B-C-D ho dei valori numerici.

Io vorrei moltiplicare i valore B-C-D nelle righe dove è presente "si" in colonna A e poi sommare tutti i risultati delle moltiplicazioni, ovviamente utilizzando una sola formula :)
Si può fare?
Grazie, buon anno a tutti.
riskismoney
Utente Senior
 
Post: 177
Iscritto il: 25/03/12 16:04

Sponsor
 

Re: [excel] condizione se e moltiplicazione

Postdi CANAPONE » 03/01/13 14:33

Ciao,

una possibile formula

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(B2:B100;C2:C100;D2:D100;--(A2:A100="sì"))


Occhio che nelle formula ho scritto "Sì" (affermativo) con l'accento.


Spero sia d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [excel] condizione se e moltiplicazione

Postdi riskismoney » 03/01/13 16:13

Direi che è perfetta. Grazie CANAPONE!
Ciao
riskismoney
Utente Senior
 
Post: 177
Iscritto il: 25/03/12 16:04

Re: [excel] condizione se e moltiplicazione

Postdi kako84 » 11/02/15 14:45

Salve a tutti,

Nel caso si volesse moltiplicare utilizzando condizioni quali E ed O?
Prendendo ad esempio il caso precedente:

=MATR.SOMMA.PRODOTTO(B2:B100;C2:C100;D2:D100;--(A2:A100="sì"))
e con A2:A100 <> "no" (nel mio caso specifico il valore dev'essere compreso in un insieme di intervalli).

Grazie per i vostri preziosi consigli
kako84
Newbie
 
Post: 1
Iscritto il: 11/02/15 14:41

Re: [excel] condizione se e moltiplicazione

Postdi ricky53 » 11/02/15 15:18

Ciao,
hai inserito il quesito in una discussione datata ... più di due anni.
Non so se i moderatori consentono questa operazione ... in caso dovresti inserire un nuovo quesito.

In ogni modo dovresti esplicitare le condizioni che hai.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [excel] condizione se e moltiplicazione

Postdi Anthony47 » 12/02/15 13:22

Ciao kako84, benvenuto nel forum.
Direi che e' meglio aprire una nuova discussione in cui pero' chiarisci esattamente che cosa hai bisogno di fare e quale e' la struttura dei tuoi dati.

Ciao, ti aspettiamo.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[excel] condizione se e moltiplicazione":


Chi c’è in linea

Visitano il forum: Maury170419, salatony e 9 ospiti