Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

SOMMS.SE() - controllo doppio

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

SOMMS.SE() - controllo doppio

Postdi gaetano73 » 19/11/12 14:00

Ciao a tutti.

Avrei bisogno che la funzione in oggetto analizzasse 2 colonne di dati anziché una sola; mi spiego meglio con un esempio.
La colonna A contiene
A1: Tizio
A2: Caio
A3: Tizio
etc

La colonna B contiene
B1: PC-Desktop
B2: PC-Portatile
B3: Smartphone
etc

La colonna C
C1: 500
C2: 500
C3: 750
etc

La funzione deve sommare i valori di C corrispondenti alle combinazioni di A e B ovvero, somma tutte le celle di C corrispondenti alla righe in cui in A trova "Tizio" ed in B trova "Smatphone".
Concludo: c'è la possibilità di farlo, magari mediante una combinazione di altre funzioni?

Grazie

Gaetano

PS: con una macro avrei risolto il problema ma, purtroppo, all'utente al quale devo consegnare il file non piacciono molto
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36

Sponsor
 

Re: SOMMS.SE() - controllo doppio

Postdi CANAPONE » 19/11/12 14:24

Ciao,

una possibilità

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(A$2:A$100="Tizio");--(B$2:B$100="Smartphone");C$2:C$100)


se hai Excel 2007 puoi usare anche somma.più.se, stesso risultato.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: SOMMS.SE() - controllo doppio

Postdi CANAPONE » 19/11/12 14:30

Ciao,

formula equivalente


Codice: Seleziona tutto
=SOMMA.PIU'.SE(C$2:C$100;A$2:A$100;"Tizio";B$2:B$100;"Smartphone")



Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: SOMMS.SE() - controllo doppio

Postdi gaetano73 » 19/11/12 15:44

Ok, grazie!!!
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36


Torna a Applicazioni Office Windows


Topic correlati a "SOMMS.SE() - controllo doppio":


Chi c’è in linea

Visitano il forum: Nessuno e 27 ospiti