Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

per sommare

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

per sommare

Postdi giorgioa » 12/10/12 20:03

Salve,
come sommare il contenuto di una casella.

espongo il problema:
in una cella ad esempio AB20 ho 2-20 ; questi 2 numeri devo sommarli, il trattino presente sta solo per distinguere
un numero dall'altro. Quale formula usare?

Grazie e saluti
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Sponsor
 

Re: per sommare

Postdi wallace&gromit » 12/10/12 20:08

mi sembra di capire che in una sola cella hai due numeri in formato di testo e vuoi sommarli, giusto?
Se così fosse ritnego l'approccio fondamentalmente sbagliato, ma una soluzione la si può trovare
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: per sommare

Postdi giorgioa » 12/10/12 21:17

Salve Wallace,
si ho provato col SINSTRA + DESTRA
preciso che i numeri in casella prima del trattino possono essere di due cifre,come quelli di destra ad una sola cifra
e che trascinando la formula trova celle vuote.
Dicevo col destra mi somma solo la 2^ cifra cio di 26 il 6.

Ciao
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Re: per sommare

Postdi wallace&gromit » 12/10/12 21:22

prova questo
=VALORE(SINISTRA(A1;RICERCA(" - ";A1))+VALORE(STRINGA.ESTRAI(A1;RICERCA(" - ";A1)+3;LUNGHEZZA(A1))))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: per sommare

Postdi giorgioa » 12/10/12 22:27

la formula mi da #VALORE

Domanda A1 sta per casella dove risiedono i numeri vero? se cosi #VALORE

CIAO
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Re: per sommare

Postdi Anthony47 » 13/10/12 00:18

La formula di w&g presuppone che il contenuto sia cifra/spazio/meno/spazio/cifre (es 2 - 22); se gli "spazi" non ci sono la formula deve diventare
Codice: Seleziona tutto
=VALORE(SINISTRA(A1;RICERCA("-";A1)-1)+VALORE(STRINGA.ESTRAI(A1;RICERCA("-";A1)+1;LUNGHEZZA(A1))))

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: per sommare

Postdi giorgioa » 13/10/12 08:08

Ciao Antony e buongiorno,
per quanto riguarda la formula funziona però, come ho accennato,
nella colonna A ci sono caselle vuote e quando la formula VALORE legge quelle caselle da
come risultato #VALORE.
CIAO
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Re: per sommare

Postdi Francesco53 » 13/10/12 08:23

Ciao puoi modificare così se ti vuoi lo zero:
Codice: Seleziona tutto
=SE(A1=0;0;VALORE(SINISTRA(A1;RICERCA("-";A1)-1)+VALORE(STRINGA.ESTRAI(A1;RICERCA("-";A1)+1;LUNGHEZZA(A1)))))


Oppure così se vuoi la cella vuota:

Codice: Seleziona tutto
=SE(A1=0;"";VALORE(SINISTRA(A1;RICERCA("-";A1)-1)+VALORE(STRINGA.ESTRAI(A1;RICERCA("-";A1)+1;LUNGHEZZA(A1)))))


Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Re: per sommare

Postdi giorgioa » 13/10/12 08:57

la formula funziona se nella casella A non trova il i numeri da sommare e se è anche vuota da formula
cioè nella casella A c'è una formula che può dare i valori
se non c'è valore da #VALORE!
CIAO
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Re: per sommare

Postdi giorgioa » 13/10/12 10:34

Salve,
Problema RISOLTO
In A faccio risultare 0.
Ok grazie ai partecipanti.
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00


Torna a Applicazioni Office Windows


Topic correlati a "per sommare":


Chi c’è in linea

Visitano il forum: patel e 7 ospiti