Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] rango di parole anziché di numeri

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] rango di parole anziché di numeri

Postdi marcoc » 12/09/12 16:33

Buongiorno a tutti,
ho necessità di inserire nella tabella:

col.A
R1 -intestazione-
R2 rosso
R3 verde
R4 blu
R5 giallo
R6 bianco

una formula tipo
=RANGO(A2;A2:A6;0)
dove nella colonna A anziché numeri ci sono parole.
La formula dovrebbe darmi come risultato "4", poiché in ordine alfabetico, la parola "rosso" è la quarta in ordine crescente, dopo "bianco", "blu" e "giallo" ma prima di "verde".

in alternativa, per il mio caso, mi andrebbe bene una formula simile a
=SUBTOTALE(4;A2:A6)
che mi riporta il valore massimo (ovvero l'ultima parola in ordine alfabetico) del filtrato.

sapete aiutarmi?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: [excel] rango di parole anziché di numeri

Postdi Anthony47 » 12/09/12 22:44

Se ti interessa il rango, in B2
Codice: Seleziona tutto
=SE(A2<>"";CONTA.SE($A$2:$A$100;"<"&A2)+1;"")
Copia poi verso il basso

Se ti interessa direttamente il #1 allora prova
Codice: Seleziona tutto
=INDICE(A1:A100;CONFRONTA(0;CONTA.SE($A$1:$A$100;"<"&A1:A100);0))

Se ti interessa l' ultimo, prova
Codice: Seleziona tutto
=INDICE(A1:A100;CONFRONTA(MAX(CONTA.SE($A$1:$A$100;"<"&A1:A100));CONTA.SE($A$1:$A$100;"<"&A1:A100);0))

Le ultime due sono da confermare con Contr-Maiusc-Enter.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[excel] rango di parole anziché di numeri":


Chi c’è in linea

Visitano il forum: alfrimpa e 24 ospiti