Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - funzione cerca

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel - funzione cerca

Postdi Sasyjoe » 11/09/12 18:49

Salve gente,

Ho problemi con la funzione cerca se non ho tutti i nomi in ordine alfabetico.

Come posso superare questo problema?

Grazie!
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Sponsor
 

Re: Excel - funzione cerca

Postdi Flash30005 » 11/09/12 20:11

In che senso?
Quale funzione Cerca... usi?

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel - funzione cerca

Postdi Sasyjoe » 11/09/12 20:45

La funzione = cerca()

Se non ho l'elenco dei nomi nell'area in cui cerca, in ordine alfabetico mi da #ND.

Grazie
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: Excel - funzione cerca

Postdi Flash30005 » 11/09/12 21:11

Prova ad usare il cerca.verticale (o cerca.orizzontale) inserendo Falso nell'Intervallo

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel - funzione cerca

Postdi Sasyjoe » 12/09/12 10:48

Flash niente



Descrivo

---------A--------------B-------------C--------
----- Nome ----- Cognome ----- Data -----

1---- Luca ----- Esposito ----- 19/3/52-----
2---- Matteo ----- Migliardi ----- 15/8/78 ----
3---- Erica ----- Di meo ----- 14/7/89 -----
4---- Simone ----- Mancuso ----- 25/6/89 -----


In cella C5 ho il valore 14/7/89
In C6 scrivo =cerca.vert(C5;A1:C4;1;Falso) Vorrei avere il nome della persona che è nata in 14/7/89

Cosa sbaglio?
Ottengo #ND se non sono in ordine alfabetico. Invece se sono in ordine alfabetico tutto apposto!



Grazie
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: Excel - funzione cerca

Postdi CANAPONE » 12/09/12 12:27

Ciao a tutti,

seguo l'esempio che descrivi

Nome

Codice: Seleziona tutto
=INDICE(A$1:A$4;CONFRONTA(C5;C$1:C$4;0))


Cognome

Codice: Seleziona tutto
=INDICE(B$1:B$4;CONFRONTA(C5;C$1:C$4;0))


Spero d'aver capito
Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Excel - funzione cerca

Postdi wallace&gromit » 13/09/12 07:33

Vedi la soluzione di Canapone (queste erano bazzecole per le sue vaste risorse!)
Per rispondere alla domanda su cosa sbagliavi: cerca.vert per definizione cerca nella prima colonna del range e restituisce il valore che si trova alla stessa riga ma ad un numero di colonne definito a DESTRA rispetto alla prima. Non è possibile cercare a sinistra come volevi fare tu, per questo si usa indice e confronta.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1419
Iscritto il: 16/01/12 14:21

Re: Excel - funzione cerca

Postdi Sasyjoe » 13/09/12 12:34

Grande Canapone.

Grazie a tutti
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27


Torna a Applicazioni Office Windows


Topic correlati a "Excel - funzione cerca":


Chi c’è in linea

Visitano il forum: Nessuno e 15 ospiti