Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - Formula troppo lenta

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel - Formula troppo lenta

Postdi Sasyjoe » 27/08/12 11:28

Salve gente

c'è un modo per velocizzare questa formula:

=INDICE(ordinealfabetico2;CONFRONTA(PICCOLO(CONTA.SE(ordinealfabetico2;"<"&ordinealfabetico2)+RIF.RIGA(ordinealfabetico2)/10000;RIF.RIGA(A1));CONTA.SE(ordinealfabetico2;"<"&ordinealfabetico2)+RIF.RIGA(ordinealfabetico2)/10000;0))

La formula funziona ed è ottima;
Il problema è che quando inserisco un nome nell'elenco ordinealfabetico2(che è composto da 1000 celle) ci vogliono 50 secondi prima che excel ricomincia a funzionare.

Capisco che 1000 celle da confrontare sono tante però diventa un problema ad esempio quando il file su altri pc "più pieni" che insomma non funzionano bene, ed il pc si blocca completamente.

Grazie
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Sponsor
 

Re: Excel - Formula troppo lenta

Postdi Flash30005 » 27/08/12 12:29

50 secondi!? Blocco Pc!?
Per questo, in queste situazioni (molte celle con formula) preferisco le macro :D

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel - Formula troppo lenta

Postdi Sasyjoe » 27/08/12 13:54

Quindi l'unica soluzione è una macro?

Vabbe in quel caso non fa niente.

Grazie.
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: Excel - Formula troppo lenta

Postdi Flash30005 » 27/08/12 14:06

Comunque fai una pulizia della cartella
"C:\Documents and Settings\TUONOME\Dati applicazioni\Microsoft\Excel"
deve contenere un solo file di nome "Excel11.xlb" e
una sotto cartella XlStart completamente vuota
I blocchi di excel a volte causano file temporanei corrotti che possono rallentare le elaborazioni di formule e calcoli


ciao

N.B. il percorso e il nome file si riferisce a excel 2003
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel - Formula troppo lenta

Postdi CANAPONE » 27/08/12 14:21

Ciao a tutti,

per non usare la formula matriciale potresti servirti anche di una colonna di servizio (la B nell'esempio) con formule del tipo

=CONTA.SE(ORDINEALFABETICO2;"<"&A2)

e far leggere i risultati della colonna a

=INDICE(ORDINEALFABETICO2;CONFRONTA(PICCOLO($B$2:$B$1000;RIF.RIGA(A1));$B$2:$B$1000;0))

per ottenere l'elenco alfabetico in ordine crescente.

Ho fatto qualche prova e mi sembra di ottenere molto più velocemente le variazioni all'elenco finale.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Excel - Formula troppo lenta

Postdi Sasyjoe » 29/08/12 11:09

Grazie Canapone.

E' molto più veloce.
Sei grandeee!
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27


Torna a Applicazioni Office Windows


Topic correlati a "Excel - Formula troppo lenta":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti