Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Confronto tra 2 liste

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Confronto tra 2 liste

Postdi toki16 » 30/07/12 13:04

Salve a tutti avrei bisogno di un aiutino con un lavoro giunto appena in tempo per rovinare le vacanze... :cry:
Avrei una lista con un elenco di circa 600 nomi e numeri in colonna A, in colonna C ho una parte di questa lista dei 600 nomi (in ordine diverso). Vorrei sapere se è possibile mettere una formula o una macro in colonna B, di modo che mi dica ad es in B1 se il nome in A1 è già compreso nella lista in colonna C, in B2 se il nome in A2 è compreso nella lista in colonna C, ecc.
Grazie a tutti per l'aiuto.
toki16
Utente Junior
 
Post: 17
Iscritto il: 11/03/10 13:55

Sponsor
 

Re: Confronto tra 2 liste

Postdi wallace&gromit » 30/07/12 13:53

Ciao toki,
con questa formula conti il numero di occorrenze del testo cercato nella colonna A che si trovano nella colonna C:
Codice: Seleziona tutto
=CONTA.SE(C$1:C$600;A1)
è sufficiente per il tuo scopo?
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Confronto tra 2 liste

Postdi toki16 » 31/07/12 21:58

Ciao wallace&gromit,
ti ringrazio infinitamente, la formula è esattamente quello che cercavo.
Mi hai accorciato di gran lunga il lavoro perché le liste da confrontare cambiano di giorno in giorno e farlo a mano mi avrebbe portato via un mare di tempo. :D
Ho fatto solo una piccola modifica alla tua formula per rendere più leggibile (almeno per me) l'elenco.

Codice: Seleziona tutto
=SE(CONTA.SE(C:C;A1)=1;"OK";"")

Grazie ancora.
Ciao
toki16
Utente Junior
 
Post: 17
Iscritto il: 11/03/10 13:55

Re: Confronto tra 2 liste

Postdi Flash30005 » 31/07/12 23:48

toki16 ha scritto:Ho fatto solo una piccola modifica alla tua formula per rendere più leggibile (almeno per me) l'elenco.

=SE(CONTA.SE(C:C;A1)=1;"OK";"")


E se dovesse trovare due o più corrispondenze?
l'OK non apparirebbe quindi, forse è meglio così
Codice: Seleziona tutto
=SE(CONTA.SE(C:C;A1)>0;"OK";"")


Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Confronto tra 2 liste

Postdi toki16 » 03/08/12 14:17

Grazie mille flash, sto usando nel file la tua formula corretta, purtroppo sono fermo all'ABC di excel!
Ciao
toki16
Utente Junior
 
Post: 17
Iscritto il: 11/03/10 13:55


Torna a Applicazioni Office Windows


Topic correlati a "Confronto tra 2 liste":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti