Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel Copiare delle colonne protette

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel Copiare delle colonne protette

Postdi papiriof » 31/05/12 09:39

E' possibile copiare tutto il contenuto (anche di soli valori) di un foglio excel parzialmente protetto ?
Ho un file di excel composto di vari fogli ,si tratta di una statistica sulle presenze, consistenze, guadagni e quant'altro dell'anno 2011 nei vari comparti della P.A. ogni foglio per ovvie ragioni non di riservatezza ma di opportunità è parzialmente protetto in alcune colonne e righe in modo tale che le celle rimaste libere fungano da interfaccia per immettere dei dati in questo modo non si corre il rischio che degli operatori tocchino delle celle che poi inficerebbero il successivo invio dei dati .
Ora per comodità a me è comodo lavorare su dei fogli del tutto simili agli originali ma liberi da vincoli di protezione
perchè con varie formule riuscirei a formare un data base e da questo popolare i vari fogli per poi successivamente copiare i soli valori sui fogli originali .
Il file è facilmente trovabile con una ricerca con : RALN_REGIONI_E_AUT_LOC_xCCNL_NAZ.x.xls
Win 7+Office 2007... ma preferisco convertire in Office 2003
papiriof
Utente Senior
 
Post: 152
Iscritto il: 16/02/10 13:23

Sponsor
 

Re: Excel Copiare delle colonne protette

Postdi Zer0Kelvin » 31/05/12 10:49

Ciao.
Puoi selezionare e copiare qualunque rettangolo di celle compreso fra due celle non protette; sel la cella A1 e la F10 non sono protette puoi copiare tranquillamente l'intervallo A1:F10.
Se usi delle macro puoi usare l'istruzione
Codice: Seleziona tutto
WorkSheet.Protect UserinterfaceOnly := True
che protegge il foglio dalle azioni dell'utente e lo lascia liberamente accessibile alle macro.
PS: perchè non hai postato il LINK al file?
[Win7,Office2010]
Condividere la conoscenza aumenta la ricchezza di tutti(Z0°K)
Dai ad un uomo un pesce e lo avrai sfamato per un giorno;insegnagli a pescare e lo avrai sfamato per sempre(Confucio)
Il sonno della ragione genera mostri(Francisco Goya)
Avatar utente
Zer0Kelvin
Utente Senior
 
Post: 305
Iscritto il: 08/04/12 11:23

Re: Excel Copiare delle colonne protette

Postdi papiriof » 31/05/12 11:56

Ti ringrazio Zero ma le celle protette con pW sono rispettivamente LE PRIME 5 RIGHE e le COLONNE A e B per cui non posso utilizzare il tuo suggerimento in particolare le colonne A e B contengono 44 +44 qualifiche + codici che a ricopiarli uno per uno è lunga ......
Win 7+Office 2007... ma preferisco convertire in Office 2003
papiriof
Utente Senior
 
Post: 152
Iscritto il: 16/02/10 13:23

Re: Excel Copiare delle colonne protette

Postdi Anthony47 » 31/05/12 21:46

Potresti creare in un nuovo foglio la replica dei dati dei fogli protetti...
Ad esempio, nel foglio nuovo in Z1 scrivi quale foglio vuoi replicare, poi in A1 metti la formula
Codice: Seleziona tutto
=SE(INDIRETTO(INDIRIZZO(RIF.RIGA();RIF.COLONNA();;;$Z$1))="";"";INDIRETTO(INDIRIZZO(RIF.RIGA();RIF.COLONNA();;;$Z$1)))
Copia sulle rimanenti colonne di riga 1, poi copia tutte le celle con formula verso il basso.
Cambiando Z1 cambia il contenuto del foglio.
Ovviamente non riporterai la formattazione, ma conoscendo come e' il foglio originale non dovresti avere problemi.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel Copiare delle colonne protette

Postdi papiriof » 01/06/12 10:20

Anthony47 ha scritto:Potresti creare in un nuovo foglio la replica dei dati dei fogli protetti...
Ad esempio, nel foglio nuovo in Z1 scrivi quale foglio vuoi replicare, poi in A1 metti la formula
Codice: Seleziona tutto
=SE(INDIRETTO(INDIRIZZO(RIF.RIGA();RIF.COLONNA();;;$Z$1))="";"";INDIRETTO(INDIRIZZO(RIF.RIGA();RIF.COLONNA();;;$Z$1)))
Copia sulle rimanenti colonne di riga 1, poi copia tutte le celle con formula verso il basso.
Cambiando Z1 cambia il contenuto del foglio.
Ovviamente non riporterai la formattazione, ma conoscendo come e' il foglio originale non dovresti avere problemi.

Ciao

Grande Anthony47 .....si può fare anche questo!!!!!!
GRAZIE
Win 7+Office 2007... ma preferisco convertire in Office 2003
papiriof
Utente Senior
 
Post: 152
Iscritto il: 16/02/10 13:23


Torna a Applicazioni Office Windows


Topic correlati a "Excel Copiare delle colonne protette":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti