Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

conteggio frequenze con condizione

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

conteggio frequenze con condizione

Postdi THECAPITAN » 10/05/12 14:19

Ciao ragazzi! Dovrei contare il numero di ore di presenza e di assenza su una scheda allievo in relazione alla frequenza di diversi moduli. Posto l'immagine della scheda http://www.filedropper.com/scheda: la colonna modulo lezione prevede per ogni cella una menu a tendina che contiene i numeri da 1 a 10 (moduli). Quello che vorrei, indipendentemente se l'allievo è presente o meno, contare la frequenza del modulo B1, B2 , B3 .. 10 per avere il totale delle ore di presenza e di assenza di quel modulo. Esempio: se nella cella modulo lezione indico B1 e poi indico le ore di presenza o assenza avrei bisogno di una formula che mi conti le presenze e le assenze di quel modulo da visualizzare nella parte in alto a destra della scheda.


Ciao.
THECAPITAN
Utente Senior
 
Post: 261
Iscritto il: 20/07/06 15:00

Sponsor
 

Re: conteggio frequenze con condizione

Postdi Flash30005 » 10/05/12 14:31

Con macro è risolvibile ma non si vedono i riferimenti delle righe/colonne
non potresti inviare solo un foglio (stralcio) delle tabelle in questione con spiegazione sul foglio stesso di ciò che vorresti ottenere indicando anche dove?
Non costringerci a ricreare un fac-simile dei tuoi dati iniziali, ok?

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: conteggio frequenze con condizione

Postdi THECAPITAN » 16/06/12 11:10

Ciao! Posto l'immagine della scheda http://www.filedropper.com/immagine
Quello che voglio ricavare è la la frequenza del modulo B1, B2 , B3 .. 10 in relazione alla presenza o assenza di un generico nominativo per avere il totale delle ore di presenza e di assenza di quel modulo.

Esempio: se nella cella E7 modulo lezione indico B7 e poi indico le ore di presenza o assenza avrei bisogno di una formula (nella parte destra) che mi conti le ore presenze e le ore di assenza effettuare in quel modulo (b1, b2, ecc).
E' evidente che se per altre giornate indicherò nella cella E7 altri valori di tipo B7 la formula dovrebbe ogni volta aggiornarsi. Inoltre se la lezione prevede 4 ore potrebbe capitare che un allievo è presente per 3 ore e assente per 1 ora, di conseguenza la formula dovrebbe prevedere anche questa situazione oppure il caso in cui è presente 2 ore e quindi assente per due ore se la lezione prevede sempre 4 ore complessive. Stessa cosa se le ore previste per quella lezione sono 5 ecc.

Spero di aver descritto meglio il problema.

Grazie.
THECAPITAN
Utente Senior
 
Post: 261
Iscritto il: 20/07/06 15:00

Re: conteggio frequenze con condizione

Postdi Anthony47 » 16/06/12 16:15

Da quello che ho capito, col layout dell' immagine:
-in L7 calcoli le presenze con la formula
Codice: Seleziona tutto
=SOMMA.SE($E$5:$E$100;$K7;$G$5:$G$100)

-in M7 calcoli le assenze con
Codice: Seleziona tutto
=SOMMA.SE($E$5:$E$100;$K7;$H$5:$H$100)

Poi copi verso il basso

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "conteggio frequenze con condizione":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti

cron