Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

formula per excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

formula per excel

Postdi giorgioa » 17/04/12 11:32

in excel AIUTO.
Premessa: si tratta di numeri
la formula in generale è la seguente:
ricerca da a1:g1 il numero di rigo h$1 col conta.se:
=SE(conta.se($A5:$G5;H$1)=1;H$1;"")
del numero ottenuto in casella h5(es.19) in I5 ne chiedo il suo vertibile
cioè se il numero fosse 35 chiedo di invertire i numeri ed il 35 diventa
53. formula in I5=concatena(destra(h5);sinistra(h5).
però se si tratta del 35 il problema sarebbe risolto ma quando incontra
i numeri in doppia cifra con finale 9 (es: 19, 29, 39, 49, 59, 69, 79, 89)
con la trasformazione di invertire i numeri diventerebbero 19=91;29=91 ecc.
Nell'arte del lotto con la conversione del vertibile il 19=11; 29=22; 39=33; 49=44
59=55; 69=66; 79=77; 89=88, fermi restando che se incontra 11 il suo vertibile
sarà 19 (11=19;22=29;33=39;44=49;55=59;66=69;77=79;88=89).
Riepilogo: convertire un numero che può essere es: 35 oppure 19 oppure 11
con le condizioni sopra descritte
:-?
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Sponsor
 

Re: formula per excel

Postdi CANAPONE » 17/04/12 12:48

Ciao,

potresti usare una tabella di conversione - per esempio- in L1:M90.

Nella colonna L i 90 numeri, nella colonna M i corrispondenti vertibili ed usare un cerca.vert

Codice: Seleziona tutto
=CERCA.VERT(H5;$L$1:$M$90;2;0)


Spero sia d'aiuto.


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "formula per excel":


Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti