Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Convalida dati

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Convalida dati

Postdi marte1503 » 03/04/12 17:42

Ciao a tutti, torno a trovarvi...

Avrei bisogno di inserire in convalida dati di cella B2 una formula che:
Controlli la cella F6 e nel caso fosse vuota mi vieti l’immissione di caratteri (nella cella B2 appunto) con la particolarità che (a patto che la cella F6 contenga un valore), B2 accetti solo la lettera X oppure x

Si può fare?

Grazie
Marte
marte1503
Utente Senior
 
Post: 174
Iscritto il: 08/01/10 20:43
Località: Como

Sponsor
 

Re: [Excel] Convalida dati

Postdi wallace&gromit » 04/04/12 12:16

Ciao Marte,
non sono sicuro di avere capito esattamente le tue richieste, però ti propongo una possibile soluzione:
in tre celle sovrapposte (io ho usato k1:k3) inserisci le formule:
Codice: Seleziona tutto
=SE(F6<>"";"X";"")
e
Codice: Seleziona tutto
=SE(F6<>"";"x";"")
e nella terza solo un apice (non apparirà niente ma sarà una cella vuota)
In B2 inserisci la formula:
Codice: Seleziona tutto
=INDICE(K1:K3;K4)

sopra alla cella B2 inserisci una casella combinata dal menu moduli, con il seguente formato: intervallo di input k1:k3 , collegamento cella: k4 altezza righe 3.
A questo punto se F6 contiene un valore puoi selezionare tra "X" "x" e vuoto, se no è sempre vuoto.
Ovviamente se alla cella f6 vuota aggiungi un valore si ripristinerà l'ultima scelta effettuata in precedenza.
Prova e dimmi se ci ho azzeccato.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1692
Iscritto il: 16/01/12 14:21

Re: [Excel] Convalida dati

Postdi Anthony47 » 04/04/12 14:54

Una leggera semplificazione di quanto proposto sopra da w&g:
-in K1 metti la formula =SE(F6<>"";"X";"")
-imposta in B2 la convalida da elenco, e come origine scrivi =K1
-usa "Messaggio di input" per spiegare all' utente che cosa puo' inserire nella cella (il messaggio gli apparira' alla selezione di B2)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 14832
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Convalida dati

Postdi marte1503 » 04/04/12 19:39

Ciao W&G ti ringrazio per l’attenzione e il tempo dedicato.

Ciao Anthony, scelgo la tua soluzione che risulta essere più snella, grazie 1000!

…Ho provato a fare qualche tentativo cercando di modificare una formula che mi aveva preparato Pietrol diverso tempo fa per risolvere un problema simile, ma all’epoca mi bastava evitare l’immissione di un valore in A2 se A1 era vuota, non avevo il problema di limitare l’inserimento a X o x

Comunque posto anche questa formula, magari potrebbe servire a qualcuno:

nella convalida in A2 scegliere "Personalizzato"
inserire la formula =VAL.VUOTO($A$1)=FALSO
e togliere la spunta a "Ignora le celle vuote"

Grazie ancora a tutti
Marte
marte1503
Utente Senior
 
Post: 174
Iscritto il: 08/01/10 20:43
Località: Como


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Convalida dati":


Chi c’è in linea

Visitano il forum: Anthony47 e 23 ospiti