Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Macro EXCEL per eliminare riferimenti a formule

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Macro EXCEL per eliminare riferimenti a formule

Postdi ddannyy » 24/02/12 20:25

Buonasera a tutti
Questa è la mia richiesta

Ho un file excel che fa riferimento ad un listino che restituisce codice e prezzo del prodotto attraverso la formula

=SE(A17="";"";CERCA.VERT(A17;Pricelist!$A:C;3;0))

Riesco inoltre a salvare il solo foglio di lavoro contenente l'offerta e non tutti i fogli della cartella grazie alla macro

Sub Rettangoloarrotondato6_Click()
ActiveSheet.Select
Cells.Select
Selection.Copy
Workbooks.Add
ActiveSheet.Paste
Cells(1, 1).Select
ActiveWorkbook.SaveAs Filename:=ThisWorkbook.Path & "\OfferteLIFE\" & Cells(11, 2) & Cells(3, 7) & ".xls"
ActiveWorkbook.Close
Cells(1, 1).Select
End Sub


Il problema è che mantenendo attivo il riferimento il file risultante è molto pesante (quanto il listino)

Volevo chiedere se è possibile evitare di copiare anche i riferimenti al listino

In manuale copiavo le singole celle e facevo incolla solo valori, ma non sono capace di farlo attraverso la macro.

Grazie per tutto l'aiuto
ddannyy
Newbie
 
Post: 2
Iscritto il: 24/02/12 20:17

Sponsor
 

Re: Macro EXCEL per eliminare riferimenti a formule

Postdi wallace&gromit » 24/02/12 22:30

ciao ddannyy
invece di
ActiveSheet.Paste
scrivi:
ActiveSheet.PasteSpecial Paste:=xlPasteValues

così ti incolla solo i valori e non le formule
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Macro EXCEL per eliminare riferimenti a formule

Postdi ddannyy » 25/02/12 14:09

Ciao
Ho impostato la macro in questo modo

Sub Rettangoloarrotondato6_Click()
ActiveSheet.Select
Cells.Select
Selection.Copy
Workbooks.Add
ActiveSheet.PasteSpecial Paste:=xlPasteValues
Cells(1, 1).Select
ActiveWorkbook.SaveAs Filename:=ThisWorkbook.Path & "\OfferteLIFE\" & Cells(11, 2) & ".xlsx"
ActiveWorkbook.Close
Cells(1, 1).Select
End Sub

Ma mi restituisce un errore 1004 di runtime

cosa potrebbe essere?
Grazie per l'aiuto
ddannyy
Newbie
 
Post: 2
Iscritto il: 24/02/12 20:17

Re: Macro EXCEL per eliminare riferimenti a formule

Postdi wallace&gromit » 25/02/12 17:02

hai ragione,
ho ripreso questa macro da un altro documento dove funzionava con ActiveSheet.
prova as sostituire ActiveSheet con Selection a me funziona con qualcosa di simile al tuo file.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "Macro EXCEL per eliminare riferimenti a formule":


Chi c’è in linea

Visitano il forum: raimea e 7 ospiti