Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cambiare il nome foglio in una formula in forma di matrice

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cambiare il nome foglio in una formula in forma di matrice

Postdi smile162 » 16/01/12 12:31

Salve a tutti,
è la prima volta in assoluto che scrivo in forum, spero di non sbagliare nulla e di riuscire ad esprimermi nella maniera più chiara possibile; premesso che sono alle prime armi con formule un tantino più “complesse” in excel e mi ci sto approcciando da assoluto autodidatta.

Il mio problema è questo: ho calcolato in alcune celle di un foglio di “Report” alcune medie pesate da un altro foglio, con una formula in forma di matrice

Es. {=SOMMA(A20:C20*’Foglio 1 mese'!A12:C12)}

Ora dovrei fare in modo che tutto il foglio “Report” si aggiorni automaticamente quando il foglio diventa “Foglio 2 mese” “Foglio 3 mese” e via di seguito.
In pratica ho bisogno di trasformare il valore ”1” del nome foglio in una variabile, in modo tale che possa richiamare di volta in volta i dati che mi servono dal relativo foglio .
Sto cercando di farlo funzionare con l’ INDIRETTO, ma non so se è la strada giusta.
Grazie molte sin d’ora a tutti quelli che cercheranno di aiutarmi!
smile162
Newbie
 
Post: 2
Iscritto il: 16/01/12 11:59

Sponsor
 

Re: Cambiare il nome foglio in una formula in forma di matri

Postdi Flash30005 » 16/01/12 14:34

Ciao Smile162 e benvenuto nel Forum

Per l'uso di Indiretto prova a non usare i nomi fogli con spazi
esempio "Foglio 1 mese" rinominalo in "Foglio1mese" (se riduci il nome in "Mese1", ancora meglio)
poi inserisci in una cella il mese esempio in AQ1 = 1
e in altra cella usa questa formula
Codice: Seleziona tutto
=SOMMA(A20:C20*INDIRETTO("Foglio"&$AQ$1&"mese!A12:C12"))


Cambiando il valore in AQ1 es.: 2 avrai i risultati del foglio "foglio2mese", etc

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Cambiare il nome foglio in una formula in forma di matri

Postdi smile162 » 16/01/12 15:05

Flash! Mai nome fu più appropriato :)
Avevo smanettato un po', ma le terribili virgolette della formula INDIRETTO mi fregano sempre! Così funziona, e se aggiungo un paio di ' riesco a tenere anche gli spazi (cosa fondamentale altrimenti avrei dovuto cambiare molte altre formule)

Non so come ringraziarti, funziona perfettamente! Se solo mi fossi iscritto prima...

Grazie!!
smile162
Newbie
 
Post: 2
Iscritto il: 16/01/12 11:59

Re: Cambiare il nome foglio in una formula in forma di matri

Postdi Flash30005 » 16/01/12 17:11

Personalmente in ogni nuovo progetto sia In Excel sia in Access (ma anche nei nomi di File in windows)
non lascio mai spazi e tendo ad abbreviare, pur lasciando intuitività nella lettura dei nomi,
togliendo tutte le stringhe inutili
e consiglio sempre di fare altrettanto
es.: "Se comandasse lo zampognaro.doc"
potrebbe divenire
SeComandZampogn.doc"
etc.

Nel tuo caso "Foglio 1 mese" la stringa Foglio è del tutto inutile
e, facendo una copia del file, potresti fare un trova (Foglio 1 mese) e sostituisci (mese1)
in tutti i fogli all'interno delle formule
avresti i nomi abbreviati dei fogli e le formule ugualmente funzionanti ;)

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Cambiare il nome foglio in una formula in forma di matri

Postdi ricky53 » 17/01/12 08:10

Ciao,
trattandosi di formule per cambiare il nome di un foglio, contenuto in tutte le formula del tuo "FILE, è sufficiente cambiare il nome del foglio con un "DOPPIO Click" sul nome del foglio (sul "Tab" in basso sulla riga di stato)
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "Cambiare il nome foglio in una formula in forma di matrice":


Chi c’è in linea

Visitano il forum: Nessuno e 21 ospiti