Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel aiuto formula o macro

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel aiuto formula o macro

Postdi Francesco53 » 21/12/11 22:30

Buongiorno a tutto il Forum, ho la seguente difficoltà:
Dovrei calcolare con la formula Conta.se(A2:F100;H1) le presenze dei dati del valore della cella H1 nel Range A2:F100,
essendo il range variabile nel numero di righe, ma essendo le stesse già conteggiate nella cella A1, vorrei sapere come
modificare la formula affinchè si adatti al valore della cella A1. Scrivo una prova che ho fatto ma con risultato errato:
=Conta.se(A2:"F"&A1;H1)
Oppure come ottenere la stessa cosa tramite una macro.
Grazie a chi mi può aiutare.
Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Sponsor
 

Re: Excel aiuto formula o macro

Postdi Anthony47 » 21/12/11 23:56

Prova con
Codice: Seleziona tutto
=CONTA.SE(INDIRETTO("A2:F"&A1);H1)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel aiuto formula o macro

Postdi Francesco53 » 22/12/11 14:56

Ciao Anthony,
purtroppo la formula da te postata, mi restituisce il valore VERO,
io avevo bisogno di rilevare le quantità presenti del valore H1,
nella serie di numeri random in "A2:F"&A1.
Grazie per la risposta, purtroppo non utilizzabile per la ricerca
delle presenze.
Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45

Re: Excel aiuto formula o macro

Postdi Anthony47 » 22/12/11 15:35

Sono disorientato, VERO come risultato di un Conta.Se non lo sarei mai aspettato; la formula completa e' esattamente =CONTA.SE(INDIRETTO("A2:F"&A1);H1)?

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel aiuto formula o macro

Postdi Francesco53 » 22/12/11 18:48

Ciao Anthony,
per quanto strano quello era il risultato ottenuto, ho riprovato ed è tutto a posto.
Scusa, probabilmente avevo (anche se ho usato il copia ed incolla) sbagliato io.
Grazie
Francesco
S.O. Vista e Office 2007
Francesco53
Utente Senior
 
Post: 647
Iscritto il: 20/02/10 18:45


Torna a Applicazioni Office Windows


Topic correlati a "Excel aiuto formula o macro":


Chi c’è in linea

Visitano il forum: Marius44 e 5 ospiti