Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[vba-excel]

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[vba-excel]

Postdi expectancy.pm » 19/09/11 12:01

Buongiorno, intanto un saluto a tutto il forum.
Avrei bisogno di aiuto per un problemino che non riesco a risolvere, provo a spiegare:
Ho un file che genera un numero x di colonne, io vorrei tramite vba identificare il numero di colonna in cui nella prima riga si trova una determinata parola poniamo ad esempio la parola "carlo". Poniamo che la parola si trovi nella colonna H, dovrei aver restituito il valore 8. Ho poi il numero di righe scritte che supponiamo sia 1455 (dato che rilevo già dal foglio) e che supponiamo si chiami "nrrighe".
Ottenuto il valore 8 vorrei poi inserire una formula (formula e non valore) che identifichi la cella H1455 in modo dinamico ovvero che si aggiorni quando le righe aumentano. Quindi qualcosa tipo INDICE(colonna8,nrrighe).
Il problena nasce dall'identificare con vba la colonna in questione e dalla formula da utilizzare alla fine.
Buona giornata a tutti.
expectancy.pm
Utente Junior
 
Post: 30
Iscritto il: 19/09/11 11:52

Sponsor
 

Re: [vba-excel]

Postdi expectancy.pm » 19/09/11 12:34

Non so quanto bene mi sia spiegato.... in conclusione a me serve:
1) identificare con vba il numero della colonna che contiene in testa la parola "carlo" es. (8).
2) una formula per poter identificare la cella(8,nrrighe), dove nrrighe un dato conosciuto.
;)
expectancy.pm
Utente Junior
 
Post: 30
Iscritto il: 19/09/11 11:52

Re: [vba-excel]

Postdi CANAPONE » 19/09/11 12:56

Ciao,

forse può essere d'aiuto

=confronta("Carlo";1:1;0)

restituirebe in lumero della colonna.

Non ho capito se hai bisogno delle coordinate della cella.

In tal caso caso basterebbe

=indirizzo(nr righe;confronta("Carlo";1:1;0))

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [vba-excel]

Postdi expectancy.pm » 19/09/11 15:32

Dunque spiego meglio: Se potessi "etichettare" le colonne la formula che inserirei è la seguente:
=indice(carlo,nrrighe). Non sapendo di volta in volta la colonna "carlo" non posso ovviamente etichettare la colonna. Come si può risolvere?
expectancy.pm
Utente Junior
 
Post: 30
Iscritto il: 19/09/11 11:52

Re: [vba-excel]

Postdi CANAPONE » 19/09/11 15:42

Ciao,

faccio un esempio

Nella matrice A1:Z1000, dal momento che conosci su quale riga cercare il dato (secondo argomento di INDICE), per trovare il numero della colonna puoi usare CONFRONTA.

=INDICE(A1:Z1000;riga conosciuta;confronta("Carlo";1:1;0))

Al posto di Carlo generalmente si mette un riferimento esterno alla formula: per esempio in AA1.

=INDICE(A1:Z1000;riga conosciuta;confronta(AA1;1:1;0))

Sicuramente devi adattare la formula al tuo caso.

Se posti un esempio, sicuramente ottieni più velocemente una risposta dagli amici del Forum.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [vba-excel]

Postdi expectancy.pm » 19/09/11 16:06

Canapone ti ringrazio moltissimo per il tuo ottimo suggerimento, tuttavia dovrei risolvere un bel pò di situazioni e la soluzione che cerco (perchè mi permetteerà di risolvere un pò tutti i problemi è la seguente):
1) identificare tramite vba il numero di colonna che contiene alla prima riga una deterinata parola.
2) poter inserire una formula con excel tipo =CELLA(8,NRRIGHECONOSCIUTE).

Ripeto il numero della riga è conosciuto.
Una soluzione del genere sarebbe ottimale, se possibile ovviamente.
Grazie mille!
expectancy.pm
Utente Junior
 
Post: 30
Iscritto il: 19/09/11 11:52

Re: [vba-excel]

Postdi CANAPONE » 19/09/11 16:17

Ciao,

purtroppo a Vba sono a zero: spero che qualche amico del Forum possa venirti in aiuto.

Seguo la discussione.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [vba-excel]

Postdi Ca.R » 20/09/11 10:00

Tieni contro che, in generale per tutto cio che puoi fare sui fogli excel esiste UN CORRISPONDENTE codice VBA.
Se hai risolto il "problema" utilizzando formule sui fogli, in teoria, non dovrebbe essere difficile "tradurre " tutto in codica VBA
Saluti
Ca.R.
Ca.R
Utente Junior
 
Post: 45
Iscritto il: 16/02/11 23:22

Re: [vba-excel]

Postdi expectancy.pm » 20/09/11 10:13

Allora ho risolto parzialmente il problema. Diciamo che ora ho il numero di colonna che mi interessa ed il numero delle righe.
in vba cells(5,1400) ed ottengo il valore della cella D1400 ma in excel come cavolo si mette questa formula?
expectancy.pm
Utente Junior
 
Post: 30
Iscritto il: 19/09/11 11:52

Re: [vba-excel]

Postdi CANAPONE » 20/09/11 10:52

Ciao,

posso parlare solo di formule

=INDIRETTO(INDIRIZZO(1400;5))

restituisce il contenuto di E1400.

=INDIRETTO(INDIRIZZO(1400;4))

restituisce il contenuto di D1400.

Forse è d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [vba-excel]

Postdi expectancy.pm » 20/09/11 12:12

Canapone non è d'aiuto.... è la soluzione al problema! Grazie mille :)
expectancy.pm
Utente Junior
 
Post: 30
Iscritto il: 19/09/11 11:52


Torna a Applicazioni Office Windows


Topic correlati a "[vba-excel]":


Chi c’è in linea

Visitano il forum: salatony e 9 ospiti