Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Aiutatemi con questa funzione di Excel per favore!!

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Aiutatemi con questa funzione di Excel per favore!!

Postdi roberto2100 » 03/08/11 14:02

Io ho un problema con Excel, ve lo espongo, sperando che mi possiate aiutare perché non ci sto venendo più fuori.
In pratica, all’inserimento del valore 1 o 2 in una determinata cella del Foglio 2 voglio ottenere nella cella accanto un risultato variabile, che deve essere ricercato in due colonne diverse del Foglio 1, sulla base di un terzo numero di riga (già conosciuto) indicato nel Foglio 2 in una cella precedente (e variabile), e nel Foglio 1 corrispondente alla numerazione di ogni riga (per es 1, 2 ,3). Come posso fare?
Per farvi capire meglio vi faccio un esempio concreto:

Ho 2 fogli
Questa formula va inserita nel secondo foglio, che, sulla base di valori conosciuti già espressi nel secondo foglio, vada a cercarsi nel primo foglio il dato relativo fra due colonne e sulla base di righe diverse.
Es:
FOGLIO 2 (voglio conoscere C, inserendo B, e avendo determinato poco prima A)
(Se nella colonna B inserisco 1, farà riferimento alla colonna B del Foglio 1, se inserisco 2, farà riferimento alla colonna C del Foglio 1)
A B C
003 1 300 €
001 2 100 €
005 2 500 €
008 1 800 €
009 1 900 €
001 1 900 €
FOGLIO 1 (questi valori sono tutti conosciuti)
A B C
001 900 € 100€
002 750 € 130 €
003 300 € 125 €
004 260 € 130 €
005 100 € 500 €
006 230 € 100€
007 150€ 250 €
008 800 € 950€
009 900 € 150 €
Qual è la formula?

Io ho provato in questo modo, ma non va. Che cosa sbaglio?
=SE(P3="ST";CERCA.VERT($K3;LISTINO!$A$3:$J$60000;7;FALSO);"NESSUNO";SE(P3="DN";CERCA.VERT($K3;LISTINO!$A$3:$J$60000;8;FALSO);"NESSUNO"))
roberto2100
Newbie
 
Post: 1
Iscritto il: 03/08/11 13:58

Sponsor
 

Re: Aiutatemi con questa funzione di Excel per favore!!

Postdi Flash30005 » 04/08/11 03:17

roberto2100 ha scritto:Qual è la formula?


Ti andrebbe bene anche una macro?

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-


Torna a Applicazioni Office Windows


Topic correlati a "Aiutatemi con questa funzione di Excel per favore!!":


Chi c’è in linea

Visitano il forum: PcBase e 10 ospiti