Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Collegamento a una casella "CONCATENATA"

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Collegamento a una casella "CONCATENATA"

Postdi luigi99 » 12/07/11 16:00

Dovrei fare un collegamento a una casella che contiene due numeri uniti da CONCATENA.
Es.: Quando la casella E9 contiene un numero uguale alla casella A14, in G9 deve evidenziarsi il contenuto della casella I9.
La casella I9 contiene due numeri risultato di una concatenazione: =CONCATENA(D14:"-";G14)
in questo caso: 6-89.
Il problema è che con la formula: =SE(E9;A14:I14), ciò avviene, ma mi viene copiato solo l'89!!! e indivua errore mi dice che la casella A14 è vuota
con: SE(E9;A14;I14) mi ripete il numero che c'è in A14 (qualunque sia)
Solo con SE(E9<>A14;I14), funziona, ma, logicamente, al contrario: infatti se E9 è uguale a A14 mi restituisce FALSO, altrimenti 6-89!!!!
Non riesco a capire come fare per impostare l'uguaglianza....devo usare IDENTICO?
Grazie. Ciao


p.s.= spero di essermi spiegato bene Immagine
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese

Sponsor
 

Re: Collegamento a una casella "CONCATENATA"

Postdi Avatar3 » 12/07/11 20:47

Non vorrei aver interpretato male ma secondo me tu sbagli la formula della condizione perché da ciò che dici
devi inserire questa formula in G9
Codice: Seleziona tutto
=SE(E9=A14;I14;"")

Prova...
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Collegamento a una casella "CONCATENATA"

Postdi luigi99 » 12/07/11 21:27

Questa funziona!!!!
Ne avevo impostata una simile, ma non mi accettava l'=!!!
Colpa degli " ?
...che significato hanno nella formula?
Grazie.
Ciao



Tanto per complicare le cose se i numeri di riferimento fossero compresi in 10 caselle es: A14:A24 e stessa cosa per le caselle da copiare (I14:I24 quelle concatenate per capirsi!!) si potrebbe avere lo stesso risultato?
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese

Re: Collegamento a una casella "CONCATENATA"

Postdi Avatar3 » 12/07/11 22:38

Gli "" (doppi apici indicano che se la condizione non è soddisfatta lascia la casella "vuota" (non vedi nulla)

Per il nuovo quesito...
Essendo oltre 7 condizioni
dovresti usare O (che sta per oppure)
guarda nell'Help in linea se non riesci posta ancora
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Collegamento a una casella "CONCATENATA"

Postdi luigi99 » 13/07/11 21:19

Questa mi funziona (sempre che non sia un caso :P ) :D
=SE(O(E8=A11);(I11))

ma quando devo inserire le altre 10 caselle non ci arrivo!!!
=SE(O(E8=A10);(I10));(O(E8=A11);(I11)) ecc. ecc.
=SE(O(E8=A10;A11;A12;A13;A14;A15);(I10;I11;I12;I13;I14;I15))
non è che due variabili (A10) e (I10) non siano gestibili con queste funzioni?
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese

Re: Collegamento a una casella "CONCATENATA"

Postdi Avatar3 » 13/07/11 22:05

A questo punto userei la funzione Cerca.Verticale
in una casella (quella di tuo interesse)
scrivi questa formula
Codice: Seleziona tutto
=CERCA.VERT(E8;A10:I24;9;FALSO)
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Collegamento a una casella "CONCATENATA"

Postdi luigi99 » 15/07/11 22:55

La formula così corretta funzione bene:
=CERCA.VERT(E8;A10:I10;9;FALSO)
anche se quando A10 non è uguale ad E8 mi risponde: #N/D
Ho provato varie modifiche, ma non riesco a inserire la serie di celle che mi servono: A10---A40 che devono essere paragonate a E8 per esprimere il risultato contenuto nelle celle da I10 a I40.
In pratica: quando il valore della cella A11 è uguale al valore della cella E8 (o viceversa) il valore da restituire è la cella I11......ma se è il valore della cella A16 a corrispondere a E8, il valore da restituire è quello della cella I16.
Per ora ho impostato una formattazione condizionale che mi evidenzia la cella I che risponde ai dati inseriti, ma dato che le 40 righe escono dal video (quindi da un certo punto bisogna scorrere il video) vorrei che il risultato fosse riportato in alto per essere visualizzato subito.
'notte
Luigi ;)
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese

Re: Collegamento a una casella "CONCATENATA"

Postdi Flash30005 » 16/07/11 00:52

Modificando la formula di Avatar3
per evitare l'errore
e inserendo in F1 (quindi in alto o nella tua visuale di finestra)
questa formula
otterrai ciò che desideri
Codice: Seleziona tutto
=SE(VAL.ERRORE(CERCA.VERT(E8;A10:I40;9;FALSO))=VERO;"";CERCA.VERT(E8;A10:I40;9;FALSO))


fai sapere se hai ancora problemi

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Collegamento a una casella "CONCATENATA"

Postdi luigi99 » 17/07/11 11:13

adesso ho capito il concetto di: A10;I24 di Avatar e che io ho erroneamente modificato :oops: :oops:
Ora la formula è perfetta :D tanto che ho potuto applicarla a un'altro paio di situazioni!!!
Se nella casella di paragone, in questo caso E8, invece di un numero ci fosse una parola o due numeri, a excel non gliene fregherebbe niente e cercherebbe comunque una corrispondenza vero?
Grazie.
Buona domenica (sotto l'acqua :-? :mmmh: :evil: )
Ciao
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese

Re: Collegamento a una casella "CONCATENATA"

Postdi Avatar3 » 17/07/11 20:40

Esatto!
:)
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Collegamento a una casella "CONCATENATA"

Postdi Anthony47 » 18/07/11 00:30

luigi99 ha scritto:Buona domenica (sotto l'acqua :-? :mmmh: :evil: )

Avatar ha scritto:Esatto!

Da me ha fatto 33°, 60% umidita' relativa, leggera brezza, mare leggerissimamente mosso...
:D :D
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Collegamento a una casella "CONCATENATA"

Postdi luigi99 » 18/07/11 15:23

Anthony47 ha scritto:Da me ha fatto 33°, 60% umidita' relativa, leggera brezza, mare leggerissimamente mosso...
:D :D


ti piacerebbe!!!!!! :lol: :lol: :lol:

ma da domani spero di mettere la pancia al sole Immagine (così per un pò vi lascio tranquilli!!!! :D :D :D )
Ciao.
Luigi
ex Autodidatta, ma ancora in cerca di grane con il computer
luigi99
Utente Senior
 
Post: 563
Iscritto il: 21/11/01 01:00
Località: Vigliano Biellese


Torna a Applicazioni Office Windows


Topic correlati a "Collegamento a una casella "CONCATENATA"":


Chi c’è in linea

Visitano il forum: Marius44, raimea e 15 ospiti