Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] Riepilogo dati da tanti fogli ad uno

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] Riepilogo dati da tanti fogli ad uno

Postdi contiend » 09/07/11 09:39

Ciao a tutti, scusate per il titolo ma non sapevo proprio cosa scrivere...

vorrei sapere se è possibile creare una formula che prenda in esame una determinata serie di celle e mi riporti quante volte 1 nome è ripetuto in quelle celle all'interno delle pagine interne.

Cerco di spiegarmi meglio:
In un file excel ho all'interno 30 fogli. Ognugno con nomi differenti.
Ho una tabella da CD3 a CD14 all'interno dei 30 fogli.
All'interno di queste cille ci sono 12 nomi, uno per ogni cella.
All'interno dei 30 fogli, i nomi possono essere diversi.

Vorrei nel FOGLIO 31, creare una tabella che mi riporti quante volte un singolo nome è stato ripetuto
Esempio:
nome a - 13
nome b - 12
nome c - 23

Infine dovrei riuscire ad ordinarlo quindi dovrebbe eserre una formula dinamica al cambiamento dell'ordine.

Aggiungo, i nomi disponibili sono circa 250 e per ogni pagina ce ne sono solo 12, sempre diversi in ogni pagina.

Spero si possa far qualcosa...
grazie dell'attenzione
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: [excel] Riepilogo dati da tanti fogli ad uno

Postdi Anthony47 » 10/07/11 00:00

Creati un elenco dei noi dei 30 fogli, ad esempio in Z1:Z30 de Foglio31; assegna a questo intervallo il nome "listaf"
Poi da A2 verso il basso creati l' elenco dei 250 nomi che possono figurare nelle celle CD3:CD14; in B2 usa questa formula
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(CONTA.SE(INDIRETTO(ListaF&"!cd3:cd14");A2))

Copia poi verso il basso.

Se vuoi l' elenco ordinato, metti le intestazioni in riga 1 poi registra una macro mentre selezioni col A e col B e poi esegui l' ordinamento che ti serve; poi tasto dx sul tab col nome Foglio31, scegli visualizza codice, metti questa macro nel frame vuoto di dx:
Codice: Seleziona tutto
Private Sub Worksheet_Activate()
Call Macro1   '<< Il nome della macro registrata
End Sub


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[excel] Riepilogo dati da tanti fogli ad uno":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti