Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Conta celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Conta celle

Postdi astrigno » 28/06/11 10:59

Salve a tutti.
Vi propongo un quesito facile-facile per voi (almeno spero).
Ho un db nel quale tutte le celle hanno un valore numerico, può essere zero, oppure un numero.
Ecco io vorrei una formula che mi contasse il nr delle celle che hanno un valore diverso da zero.
Sono stato chiaro?
astrigno
Utente Junior
 
Post: 89
Iscritto il: 17/05/11 10:01
Località: genova

Sponsor
 

Re: Conta celle

Postdi Avatar3 » 28/06/11 11:30

Se è un database di access
crea una query della tabella con conta record
vai in modifica query e aggiungi
Where TuoCampoNumerico <> 0;

Se invece parli "impropriamente" di db in excel puoi risolvere con una macro

Con il codice
Codice: Seleziona tutto
UR = Worksheets("Foglio1").Range("A" & Rows.Count).End(xlUp).Row

Conti le righe piene della colonna A (cambia sia nomefoglio e colonna adattandola alla tua esigenza)

Poi aggiungi
Conta = 0
For RR = 1 to UR
If Worksheets("Foglio1").Range("A" & RR).value <> 0 then Conta = Conta+1
next RR

Msgbox Conta
End Sub

Oppure con una formula
Codice: Seleziona tutto
=CONTA.SE(A1:A100;"<>0")


Il range A1:A100 adattalo alla tua colonna con i numeri
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Conta celle

Postdi astrigno » 28/06/11 12:34

Sono senza parole, che dire.....soluzione a prova di cretino.
grazie
astrigno
Utente Junior
 
Post: 89
Iscritto il: 17/05/11 10:01
Località: genova

Re: Conta celle

Postdi Avatar3 » 28/06/11 13:22

Il motto è:
"Non abbattersi mai" :)

Ho iniziato a fare domande "cretine" anche io e forse continuerò a farle se occorrono per risolvere un problema

piano piano si impara...

;)
Per il funzionamento delle macro si deve impostare la protezione a Bassa o Media.
Menu Strumenti -> Macro -> Protezione...
Avatar utente
Avatar3
Utente Senior
 
Post: 569
Iscritto il: 04/04/11 09:04

Re: Conta celle

Postdi ricky53 » 28/06/11 22:48

Ciao,

Avatar: ben scritto: "Non abbattersi mai" !!!

Un mio amico (il Vecchio Saggio) diceva: chi non fa domande non ha capito !!!
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "Conta celle":


Chi c’è in linea

Visitano il forum: Nessuno e 20 ospiti