Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Valore massimo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Valore massimo

Postdi toki16 » 26/03/11 12:26

Salve a tutti,
avrei un bisogno di un po' d'aiuto...
Ho 3 righe

A|50|097|127|212|245
B|51|105| 176|192|260
C|01|008|049|020|015

le prime due sono dei valori calcolati, C contiene la differenza.
So che per conoscere il valore minimo e massimo posso usare la funzione MIN e MAX ma per sapere che la differenza maggiore (in questo caso 49) è a favore di B come posso fare?
Grazie in anticipo per l'aiuto!
toki16
Utente Junior
 
Post: 17
Iscritto il: 11/03/10 13:55

Sponsor
 

Re: [Excel] Valore massimo

Postdi Anthony47 » 26/03/11 16:27

Ad esempio con la formattazione condizionale:
-selezioni A1:E1
-imposti la formattazione condizionale con Condizione1=La formula e', e con formula =E(MAX($A$3:$E$3)=A$3;A$1>A$2)
-premi Formato e assegni un colore a piacere
-selezioni A2:E2 e ripeti, ma con la formula =E(MAX($A$3:$E$3)=A$3;A$1<A$2)

Da adattare al tuo layout dati

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Valore massimo

Postdi toki16 » 26/03/11 17:57

Ciao Anthony47,
grazie dell'aiuto.
Non ho capito la formula, quindi mi sono limitato ad applicarla e a me funziona così, non se ho fatto giusto o sbagliato: la cella D3, contenente il numero 176, viene evidenziata.
Già va bene così e ti ringrazio, sarebbe il massimo se si riuscisse a scrivere in un'altra cella, diversa da quella contenente i dati, la lettera B.
In pratica avere in una cella, con la formula =MAX(A3:E3), il valore di differenza più elevato (49) e, nella cella a fianco, la lettera B che indichi di chi è in favore la differenza.
toki16
Utente Junior
 
Post: 17
Iscritto il: 11/03/10 13:55

Re: [Excel] Valore massimo

Postdi Anthony47 » 26/03/11 22:31

Allora potresti calcolare in riga 3 la sola differenza tra prima e seconda riga (formula del tipo =A1-A2) senza "valore assoluto"; poi calcoli il massimo con la formula
Codice: Seleziona tutto
=MAX(MAX(A3:E3);ASS(MIN(A3:E3)))
e la riga con
Codice: Seleziona tutto
=SE(ASS(MIN(A3:E3))>MAX(A3:E3);"B";"A")


Oppure lasci come e' adesso e per il calcolo della riga usi la formula
Codice: Seleziona tutto
=SE(ASS(MIN(A1:E1-A2:E2))>MAX(A1:E1-A2:E2);"B";"A")
che pero' confermerai con Contr-Maiusc-Enter (non col semplice Enter)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Valore massimo

Postdi toki16 » 26/03/11 22:58

Grazie mille per la gentilezza e la prontezza nelle risposte.
La formula va alla grande, era prorpio quello che cercavo. :D
toki16
Utente Junior
 
Post: 17
Iscritto il: 11/03/10 13:55


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Valore massimo":


Chi c’è in linea

Visitano il forum: Nessuno e 121 ospiti

cron