Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI

Postdi pietro171178 » 06/01/11 14:59

Ciao a Tutti, vorrei sapere se esiste una formula sintetizzata che possa sommare delle celle da molti fogli di calcolo (circa 25).
Se così fosse eviterei di costruire una formula lunghissima.
Es. =SOMMA(foglio1!A1+foglio1!A2+foglio2!A1+foglio2!A2) etc. etc
Grazie Mille
Pietro
pietro171178
Utente Junior
 
Post: 23
Iscritto il: 23/11/10 17:23

Sponsor
 

Re: FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI

Postdi CANAPONE » 06/01/11 16:25

Ciao, in A4 del Foglio1 potresti scrivere:

=SOMMA(Foglio1:Foglio25!A1:A2)

Spero sia d'aiuto.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI

Postdi pietro171178 » 09/01/11 11:42

Ciao Canapone, grazie mille però purtroppo la tua formula và in errore.
pietro171178
Utente Junior
 
Post: 23
Iscritto il: 23/11/10 17:23

Re: FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI

Postdi Anthony47 » 09/01/11 14:59

Canapone e' un bravissimo interprete di excel (e immagino anche di altri "strumenti"), ma temo non abbia il potere della divinazione. Quindi ti ha suggerito "il metodo", cioe' l' uso del "riferimento 3d" (vedi l' help on line di excel alla voce "riferimento 3d"); dovrai adattare la formula al nome dei tuoi fogli, e comunque se qualche singola cella che sommi contiene un valore di errore il risultato sara' anche lui un valore di errore.

Qualche considerazioni in piu' potrebbe essere possibile conoscendo il layout della tua cartella di lavoro, la formula che hai usato, l' errore che ti viene restituito.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI

Postdi pietro171178 » 10/01/11 11:58

Buongiorno a Voi, non metto certo in dubbio l' esperienza di chi mi consigla, anzi ringrazio
Capisco assolutamente che non si possono fare miracoli con le poche informazioni che diamo nell' esposizione dei problemi che poi vengono interpretati in modo soggettivo.
Riporto la formula copiata nella cella che "funziona" forse in questo modo potete capire cosa intendo.
E' solo un problema di spazio e comodità oppure semplificazione.
Ecco la formula:

Codice: Seleziona tutto
=SOMMA('giorno1 '!I9+'giorno1 '!I10+giorno2!I9+giorno2!I10+giorno3!I9+giorno3!I10+giorno4!I9+giorno4!I10+giorno5!I9+giorno5!I10+giorno6!I9 +giorno6!I10+giorno7!I9+giorno7!I10+giorno8!I9+giorno8!I10+giorno9!I9+giorno9!I10+giorno10!I9+giorno10!I10 +giorno11!I9+giorno11!I10+giorno12!I9+giorno12!I10+giorno13!I9+giorno13!I10+giorno14!I9+giorno14!I10 +giorno15!I9+giorno15!I10+giorno16!I9+giorno16!I10+giorno17!I9+giorno17!I10+giorno18!I9+giorno18!I10 +giorno19!I9+giorno19!I10+giorno20!I9+giorno20!I10+giorno21!I9+giorno21!I10+giorno22!I9+giorno22!I10 +giorno23!I9+giorno23!I10+giorno24!I9+giorno24!I10+giorno25!I9+giorno25!I10)


Mi chiedevo se fosse possibile sintetizzare questa formula.

Spero in questo modo di essere stato più preciso ed esplicativo.
Grazie come sempre
Pietro
pietro171178
Utente Junior
 
Post: 23
Iscritto il: 23/11/10 17:23

Re: FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI

Postdi Flash30005 » 10/01/11 12:16

Addattando la formula di Canapone alla tua esigenza avrai

Codice: Seleziona tutto
=SOMMA(Giorno1:Giorno25!I9:I10)


Se va in errore significa che hai dei dati non numerici in qualche cella, come dice Anthony

perché ti assicuro che la formula l'ho testata e funziona!

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI

Postdi Anthony47 » 10/01/11 14:16

Poiche' nei nomi fogli ci sono degli spazi bisogna usare il delimitatore "apostrofo", cioe':
Codice: Seleziona tutto
=SOMMA('giorno1 :giorno25'!I9:I10)

Presuppone che giorno1 sia il tab piu' a sx e giorno25 sia il tab piu' a dx

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI

Postdi pietro171178 » 10/01/11 16:16

Applicando la tua formula Antony funziona benissimo!
Come dicevo nessuno mette in dubbio le capacità e il sapere di chi risponde: trovo che dover trovare soluzioni cercando di interpretare quello che chi chiede ha in testa, e' davvero ammirevole.
Complimenti a Tutti come sempre!!!
Pietro
pietro171178
Utente Junior
 
Post: 23
Iscritto il: 23/11/10 17:23


Torna a Applicazioni Office Windows


Topic correlati a "FORMULA CORTA PER SOMMARE CELLE DI 25 FOGLI":


Chi c’è in linea

Visitano il forum: Nessuno e 24 ospiti