Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel Cerca valore

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel Cerca valore

Postdi nuni81 » 22/11/10 12:42

Ciao a tutti,
potete aiutarmi? Ho una tabella di questo tipo:
________________Aprile Maggio Giugno
Nome e cognome 1 P____P
Nome e cognome 2 P__________P

Vorrei avere una tabella cosi fatta:
Nome e cognome 1 Aprile Maggio
Nome e Cognome 2 Aprile Giugno

In pratica dove inserita la P il mese corisspondente, se la P non presente, nessun valore
Spero di esssermi spiegata
Grazie mille
nuni81
Newbie
 
Post: 1
Iscritto il: 22/11/10 12:31

Sponsor
 

Re: Excel Cerca valore

Postdi ricky53 » 22/11/10 16:01

Ciao,
prima di tutto benvenuta nel nostro forum.

I dati che hai sono molti?

Le tue esigenze sono proprio e solo queste che hai descritto?

L'esperienza insegna che si semplifica il problema per renderlo comprensibile ma si rischia di trascurare informazioni importanti.

Che versione di Office utilizzi?
Su può fare con formule mediante celle di appoggio o con una macro.
Quanta conoscenza del VBA hai?

Per esempio
in colonna "A" ci sono i nomi, in "B" i cognomi in "C" aprile, in "D" maggio,

in una cella di appoggio "AA2" scrivi: =SE(C2 = "P"; C$1; "")
selezioni a trascini a destra ed in basso
poi con copia/incolla speciale valori sostituisci le colonne A, B, C, D, ...

E' un esempio per iniziare magari va bene e si risolve.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Excel Cerca valore

Postdi CANAPONE » 23/11/10 18:02

Ciao, una possibile soluzione:
Codice: Seleziona tutto
=SE(COLONNE($A$1:A$1)<=CONTA.SE($B$2:$J$2;"P");INDICE($B$1:$J$1;PICCOLO(SE($B$2:$J$2="P";RIF.COLONNA($B$1:$J$1)-1;"");COLONNE($B2:B2)));"")

E' una formula matriciale, per funzionare deve essere confermata/inserita con control+maiusc+enter: se inserita bene ti apparirà abbracciata da due parentesi graffe.

La formula punta sui mesi in B1:J1 (aprile-dicembre) e riga per riga controlla la presenza delle P.

Ti giro il foglio dove ho provato la formula: nell'esempio l'ho copiata in L2 e trascinata sino T4.

http://wikisend.com/download/931856/PCFACILE.xls

Le formule sono evidenziate con sfondo giallo.

Un rapportino molto veloce nomi/mese (non dinamico però) lo potresti ottenere anche con una tabella pivot.


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Excel Cerca valore

Postdi Anthony47 » 23/11/10 23:03

Benvenuto nel forum a nuni81 e a CANAPONE (brillante soluzione!).

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel Cerca valore

Postdi ricky53 » 24/11/10 00:18

Ciao Canapone,
benvenuto e ben trovato.

Bella soluzione la tua.
Ho solo un dubbio perchè lei aveva scritto
in pratica dove inserita la P il mese corrispondente, se la P non presente, nessun valore

che io avevo interpretato come lasciare una cella vuota se la "P" non c'è) per avere mesi uguali nella stessa colonna.

La tua soluzione accorpa i mesi, non è che io lo consideri un errore ma aspettiamo cosa ci dirà lei in base alle sue necessità.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "Excel Cerca valore":


Chi c’è in linea

Visitano il forum: albval e 31 ospiti