Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Somma voti fantacalcio .. help !!!

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Somma voti fantacalcio .. help !!!

Postdi scirea1976 » 18/11/10 22:01

Anthony pensavo fosse inutile aprire un nuoco topic ... comunque
Questa formula è l'ultima che mi hai postato
Codice: Seleziona tutto
=SE(E(SOMMA(((E$3:E$13="-"))*(B$3:B$13=B15))>0;SOMMA(((E$3:E$13="-"))*(B$3:B$13=B15))>=SOMMA((B$15:B15=B15)*((D$15:D15<>"-"))));SE(E(D15<>"+-";SOMMA(--(LUNGHEZZA(E$14:E14)>0))<3);D15;"");"")

Ho postato un file a questo indirizzo http://www.realfanta2009.altervista.org/scirea.xls
dove ci sono 2 esempi, nel primo quello di destra la formula mi fa la sostituzione della sostituzione anche se la prima ha come voto un numero ( invece dobrebbe farla solo se il voto e nullo "-")... nel secondo la formula si comporta in modo corretto.. spero di essere stato chiaro ... ciao e grazie
scirea1976
Utente Junior
 
Post: 21
Iscritto il: 08/11/10 04:44

Sponsor
 

Re: Somma voti fantacalcio .. help !!!

Postdi Anthony47 » 18/11/10 22:34

Il tuo messaggio era rimasto nelle pieghe della discussione principale; era per evitare questa e altre confusioni che avevo pregato di lasciare quella discussione solo all' argomento di gigilatrottola.

Veniamo alle formule; dopo una settimana non ne ricordo piu' la genesi ma mi pare che ci sia un range impostato male (relativo all' esame delle sostituzioni avvenute); quindi in E15:
Codice: Seleziona tutto
=SE(E(SOMMA(((E$3:E$13="-"))*(B$3:B$13=B15))>0;SOMMA(((E$3:E$13="-"))*(B$3:B$13=B15))>SOMMA((B$14:B14=B15)*((D$14:D14<>"-"))));SE(E(D15<>"+-";SOMMA(--(LUNGHEZZA(E$14:E14)>0))<3);D15;"");"")
Contr-Maiusc-Enter

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Somma voti fantacalcio .. help !!!

Postdi scirea1976 » 18/11/10 23:33

Provata e funzionante , la testero piu volte.. poi ti faccio sapere.. grazie mille
scirea1976
Utente Junior
 
Post: 21
Iscritto il: 08/11/10 04:44


Torna a Applicazioni Office Windows


Topic correlati a "Somma voti fantacalcio .. help !!!":


Chi c’è in linea

Visitano il forum: Marius44, patel, saxas e 12 ospiti